Ui.Vision RPA Chrome extension: Migration from Manifest V2 to Manifest V3

Not able to upload, as i am a new user, u r not allowing new user upload files

@Eltal I changed your “trust level”, now the file upload should work.

@Eltal Thanks. And the same macro works OK in V6.2.8?

sure did worked fine

Thanks a lot for the video. That was helpful! It shows that with the 2nd run the OPEN command fails because of the toPlay error. And because of this, the web page is not loaded. And because of this, you get the “can not connect” errors next. We will fix this asap.

The new V6.3.2 solves all bugs reported in this thread. Of course, if you still find problems, please keep reporting them here.

Unfortunately new issues have been discovered.

Edit: This issue is fixed with V6.3.3.


Meanwhile another problem has been discovered: V6.3.1 and V6.3.2 suffer from a memory leak. It shows “only” if you run macros in a loop for a long time. Memory usage increases and at some point the extension crashes.

Reports about this here:

Solutions:

  • One workaround is to go back to V6.2.8 until the issue is fixed (see above).
  • Another solution is to use external looping via the command line. The command line is the best method for 24x7 non-stop automation anyway, as it also avoids browser memory issues.

Screenshot of the memory leak:

The new V6.3.3 solves all bugs reported in this thread. Of course, if you still find problems, please keep reporting them here.

It happened on 6.3.3

1 Like

it was fine in the first few day, then all the problems came back. RUN_TEST_CASE, No tab with id. This is quite stress.

If you have problems with V6.3.3, please try the new V7.0.5 Beta version here:

With V7.0.5 the transition to manifest V3 is completed, the “only” thing left to do is finding and fixing bugs. So if you spot any bugs, please let us know and report them in the forum.

RPA V7.0.7 is available now. This release completes the transition :partying_face:

What remains to be done is to find and fix remaining bugs - if any. So please continue to report any issues that you might encounter!

V7 uses Manifest V3 and this brings a breaking change for ExecuteScript**_Sandbox**. To be able to keep the very useful Sandbox version we had to switch ExecuteScript_Sandbox to a new Javascript engine. This works, but the new engine is somewhat limited:

The workaround for both issues is to switch to executeScript instead. ExecuteScript (which runs in the website) remains 100% unchanged. To modify your existing macros the (only) change you need to make is to

  1. Change the command from _Sandbox to executeScript (example here or here)
  2. Make sure a website is loaded in the browser, because executeScript runs inside the website. Any website or even a local HTML file will be sufficient.

But for most simple Javascript calculations the new JS engine should work just fine. To test if your Javascript runs in the new ExecuteScript_Sandbox you can use this website:

I can not use csvSaveArray like before, which part should I change and change it into what to make this works with new V7.0.7? @admin

Or could you just post a backup of V6.3.3 so my work is still working in the moment?

@kolor_blind If needed, you can install the earlier version V6.2.8 from the RPA archive .

hi @admin , I’ve posted in the main channel, but also reporting here for record purposes.

The Command of store value to clipboard does not work with the new version, shows the error of:
“document not define”

image

Wonder how do we fix this error

V6.2.8 is so slow, and the error no tab with id usually pops up.
Please make V6.3.3 to the RPA archive. @admin.
I’m so busy right now so I can’t fix all the script and test them all. For example, after V7.0.7, the script to play audio is not working anymore. I change executeScript_Sandbox to executeScript and it’s not working. I really need V6.3.3.