Ui.Vision RPA Chrome extension: Migration from Manifest V2 to Manifest V3 [Completed 😃]

It happened on 6.3.3

1 Like

it was fine in the first few day, then all the problems came back. RUN_TEST_CASE, No tab with id. This is quite stress.

If you have problems with V6.3.3, please try the new V7.0.5 Beta version here:

With V7.0.5 the transition to manifest V3 is completed, the “only” thing left to do is finding and fixing bugs. So if you spot any bugs, please let us know and report them in the forum.

RPA V7.0.7 is available now. This release completes the transition :partying_face:

What remains to be done is to find and fix remaining bugs - if any. So please continue to report any issues that you might encounter!

V7 uses Manifest V3 and this brings a breaking change for ExecuteScript**_Sandbox**. To be able to keep the very useful Sandbox version we had to switch ExecuteScript_Sandbox to a new Javascript engine. This works, but the new engine is somewhat limited:

Update July 22: The array issue is solved. In V7.1.12 (and newer) the executeScript_Sandbox command supports returning arrays again :smiley:

The workaround for both issues is to switch to executeScript instead. ExecuteScript (which runs in the website) remains 100% unchanged. To modify your existing macros the (only) change you need to make is to

  1. Change the command from _Sandbox to executeScript (example here or here)
  2. Make sure a website is loaded in the browser, because executeScript runs inside the website. Any website or even a local HTML file will be sufficient.

But for most simple Javascript calculations the new JS engine should work just fine. To test if your Javascript runs in the new ExecuteScript_Sandbox you can use this website:

I can not use csvSaveArray like before, which part should I change and change it into what to make this works with new V7.0.7? @admin

Or could you just post a backup of V6.3.3 so my work is still working in the moment?

@kolor_blind If needed, you can install the earlier version V6.2.8 from the RPA archive .

hi @admin , I’ve posted in the main channel, but also reporting here for record purposes.

The Command of store value to clipboard does not work with the new version, shows the error of:
“document not define”


Wonder how do we fix this error

V6.2.8 is so slow, and the error no tab with id usually pops up.
Please make V6.3.3 to the RPA archive. @admin.
I’m so busy right now so I can’t fix all the script and test them all. For example, after V7.0.7, the script to play audio is not working anymore. I change executeScript_Sandbox to executeScript and it’s not working. I really need V6.3.3.

I’ve just received a run test case error a few moment ago.
V7.0.7 is making us change so many details, and still got the error of old version.
Could I just get a V6.3.3 as soon as possible?

Hi, why do you think that 6.2.8 is slow? Actually, V6.3.3/V7.0x is a bit slower because the new manifest V3 makes us to do things a bit more complicated.

@alex_loh the !clipboard variable issue is solved with V7.0.8.

1 Like

because I have tested it on my device so many times.
V6.2.8 is more likely to have erors than V6.3.3.
And it might be slower or faster depend on the internet speed but V6.3.3 is definitely better.

Could you just make it instead of recommend me using V6.2.8?

Gotcha, thanks @admin for helping out!

Also just want to report that version 7.07 still crashes on chrome. I was running the scripts midway and the page itself crashed :frowning:

The only difference this time is that the app extension stays, last time when it crashed the app will disappear from the extension.

Would the older versions help with the crash? Or version 7.0.8 help mitigate it?

Hi! :wave:
The Memory leak issue seems to be back in 7.0.7. :face_with_diagonal_mouth:

1 Like

Johan, is the out of memory bug causing the app to crash for you as well?

2 No tab with id errors in a row.

I’m hopeless with this version. Please make V6.3.3 to the archive, and I can continue with my works, while you can fix bugs in that time.

@admin @ulrich

@johan Do you have a test case for the memory leak issue? I was running the “demoFrames” macro for more than 1000 loops without an issue (2-3 hours).

2 No tab with id errors in a row.

How do you start the macro? (I mean, what command line do you use in the task scheduler. And do you get the same error if you start one of our macros e. g. DemoFrames?)