XClick Green screen

Hi! I’m using a PRO version of Kantu.

I am on normal mode and I am using XClick to click some element and it is showing the green screen. It seems to locate the image I want to be clicked (it is highlighted on red rectangle) and then after the green screen went off, it won’t click on it but says that the step has passed.

If I am on Desktop Automation mode, it seems to work as expected but I do not want to use this option as it looks all throughout my whole screen and I just wanted to look at the browser.

I am using MacOS Catalina version and the latest version of Kantu Chrome extension.

Any input on this?
Thank you and looking forward to your reply.

Just to clarify the issue: XClick works in desktop mode, but fails in “browser only” mode?

As a test, if you run the Demo-XClick macro, does it have the same issue?

Hi ulrich,

Thank you for responding.

On my scenario, I believe it clicks on the page as well, but only at the incorrect part of the screen Usually it clicks a little bit higher that the object I want to be clicked.

To answer your question – Yes, I am having the same issue using the Demo XClick Macro. It is working OK on desktop mode but fails in “browser mode”. Attaching some screenshots for your reference.

Hmm… from the screenshots it seems the RPA software finds the right location visually, but indeed, the mouse is moved to the wrong location!

This means it is not a Catalina permission issue, it is more likely to be related to the screen resolution => What kind of Mac/Macbook is this? How much DPI does the screen have? Is it a multi-monitor setup?

I’m using a MacBook Pro (13-inch, 2017, no touch bar). I’m only using the Mac itself at the moment but I use “multiple” desktops; no extra monitors.

Colour LCD:
Display Type: Built-In Retina LCD
Resolution: 2560 x 1600 Retina

DPI is 227.

I have tried to use one Desktop only but the issue still persists. Hope you can take a look on you end.

Any thoughts on this? Do I need to adjust some settings on my Mac?

last month, i also faced same situation in windows 10 chrome . screen gets green, passed the step and moved to next step.
i clear the cache and delete history and after that it worked for me.
May be the same case at your end too.

You can give a try .

1 Like

Hi Sachin, thank you for your input.

I have tried this troubleshooting trick but I’m still encountering the error. :cold_sweat: Maybe it has something to do with MacOS. Only the experts can tell! :nerd_face:

May I also ask if am I supposed to see the green screen everytime I use the XClick command?

yes jp
xclick give me green screen every time when it runs.
i think its natural but i did not raise the question as i am getting things as expected after this command.

I am sorry as that trouble shoot did not solve your things.

1 Like

Hi. A related issue is encountered.
Details here: XClick moves mouse to incorrect position

Thanks again, Sachin!

I hope we get a response soon.

Yes. The green screen is used to calibrate the browser window. However it is used only at the first XClick command of every macro.

About the main issue (shifted click position): We are not sure what is causing this on some machines. It works on our Macbooks, but of course that does not help you.

As a test: Can you please check if you see the same issue with

You do not need to reinstall the XModules as one installation works for all browsers. Just the add the RPA software to the browsers and run the DemoXClick macro. Thanks!

Same for me. Xclick suddenly stopped clicking properly and started showing the the same problem as op. Tested this in windows and its not clicking its located target properly neither in chrome nor firefox

We confirmed the issue on the Mac now (Chrome, Firefox and Edge). The same problem shows with the old V5.3.17 and the new V5.5.7 - so it is not an update issue. => We are testing this further. It seems “something” has changed… and we need to find out what this is.

But on Windows all works fine in our test. => Can you maybe add a screencast of your Windows test?

So interesting discovery I found in testing, In Chrome, the xclick does manage to properly click its target when UI Vision is in its default 100% zoom view. When I adjust the zoom of UI vision, the problem reappears. However I still cannot get coordinates to click properly in desktop mode

Thanks! Hope this gets resolved soon.


Similar Issue

Waiting for a fix on this … :eyes::blush: