XClick Desktop Mode - Image not found

I’m getting an error when doing XClick on an image.

* [info] Executing: | XClick | test_dpi_192.png | #left |
* [error] Image 'clickme_dpi_192.png' (conf. = 0.8) not found
* [info] Macro failed (Runtime 8.73s)

The tried that above on desktop mode and please note that I have been using the same script for 3 weeks, it is just today that it failed. I’m not on dual-screen mode. I’m using a MacOS running in Catalina / Chrome browser.

I also tried capturing a new image and tried XClick on it but still doesn’t work.

There is still an open issue with XClick browser mode found on this link:

Any inputs on this XClick error?

As a quick test, does a lower confidence level work, maybe try 0.6?

XClick | test_dpi_192.png@0.6 | #left

What happens if you test the image search with the “Find” button? Is the image found somewhere else, or not at all?

It is found. Highlighted with a red rectangle. But the XClick doesn’t work.

Hi Ulrich,

Taking a screenshot using :eye:Select button on XClick and OCRExtract commands take a different part of the screen as screenshot. Hope you can take a look.

It sounds like this issue: Image found, but click in the wrong place:

See here: macOS: XClick on image shifted

=> Maybe using desktop automation mode (XDesktopAutomation | true) helps you, too?