Ui.Vision RPA Chrome extension: Migration from Manifest V2 to Manifest V3

@admin I run a ps1 file by powershell, and the script inside that file would run macro.
This is the script from ps1 file I run by powershell:

Start-Sleep -Seconds 5

Stop-Process -processname chrome

Start-Sleep -Seconds 10

Start-Process -FilePath "C:\Program Files\Google\Chrome\Application\chrome.exe" '--profile-directory="Profile 12" "https://www.google.com/"'

Start-Sleep -Seconds 20

Start-Process -FilePath "C:\Program Files\Google\Chrome\Application\chrome.exe" -ArgumentList '"file:///G:/My Drive/uivision/ui.vision.html?macro=F1-payoutAuto.json&closeRPA=1&closeBrowser=1&direct=1" --profile-directory="Profile 12"' 

I never heard of DemoFrames. What is that and how could I test it? Does it help me to make the autorun macro not having the no tab with id error? Could you guide me?

I just know if I open UI Vision by clicking on extension icon, and hit Play Macro, it would run perfectly fine.

Hi @kolor_blind Can you please try adding PAUSE | 3000 at the top of your macro? Does this help? (= avoid the “no tab ID” errors)?

Could you please mark this problem as one of your hardest problem to solved? Because adding pause doesn’t help. I tried adding BringBrowserToFront, tried PAUSE | 10000, tried open Chrome and wait for 30 seconds or even 1 minute and the start the UI Vision.

All of the methods above are not working. The problem is not in the script. It’s in the way UI Vision interact with Chrome. Not only no tab with id, but there are several other warnings that I don’t know how to get rid of.

This is very high on our todo list. We will address it as soon as the Manifest V3 transition is done.

Note: You are right that the problem is related to interaction with Chrome. Because if you use “only” XClick, XType, ExecuteScript_Sandbox and other non-web commands, the issue does not happen.

Yes, but all I want to do is just web related commands, because I want them to play in the background in my VPS without my attention. That way the macro could run while I don’t even open VPS, so I could run them in my sleep.

Please try to figure this out. And if you could, make a more specific instruction on how to use executeScript in this new Manifest V3, because my macros are all messed up after V3. I’m having a problem with 2 similar structure macros but give different results that I’ve already posted it on forum.

no reply to this? my macro is crashed and could you help me? @admin

@kolor_blind the “tab ID” issue is on our todo list. We do not have a fix for it yet. Or are you referring to another issue?

I was posting a new post about that problem but @ulrich got me through.

I’ve just read the OP so I’m linking my issue here, as requested:

There’s also a similar issue here:

Finally, you say we can run v6.2.8 “in parallel”, does that mean if I install it another button appears next to the current version’s button? I don’t have to uninstall anything?

Thanks.

May 9th, V7.0.11: The list of known issues is getting smaller with each update. As of V7.0.11 the current list of open issues is:

If you notice anything else, please report it in the forum.

1 Like

I’m struggling to run these two in parallel. Can someone tell me where v6.2.8 is installed please? I can’t find it in the Documents folder. I wish to copy my macros to it so it can be used.

Also, do I have to install x-modules again?

For reference, when I installed 6.2.8 from the hidden web-page, it doesn’t pin a button in Chrome - v7.0.9 remains. One has to go into Chrome’s extension page and open it from its details page.

@admin maybe you can correct me if I’m wrong.

Also, do I have to install x-modules again?

No - one installation works for all Editions + Firefox + Edge + Copyfish :wink:

I wish to copy my macros to it so it can be used.

  • If in browser storage mode the solution is to export (backup) the macros and then import them in the new version.

  • In hard-drive storage mode just point all versions to the same UI.Vision home folder. This is very convenient.

Thank you, although it’s not finding my installed x-modules :person_shrugging:

So would there be a problem if I installed x-modules again? Might it overcome this issue and be found?

The currently installed version is v1.0.6. Do I need to uninstall that; if so, where is it located?

I’m a bit nervous removing it, however, because I know it worked before the update to v7.0.x

Just reinstalling the XModules gives you the latest version.

Unexplained halts.

Popping this issue in here as it’s happened to me several times on two separate days, and seemingly the OP of the post below, too.

In summary, for me, it halted on the following commands (mostly storeText):

  • storeText
  • assertElementPresent

V7.0.13 has been released today - it fixes some of the reported issues.

Where is the change-log page for new releases please?

[Added]: found it: What's new with UI.Vision RPA - Visual Automation plus Selenium IDE

1 Like