Script suddenly stop

Hello,

i’m on UI VISION 7.0.11 When i run a macro sometimes script suddenly stop No error in log. The counter does not move and the commands after are not executed (I launch mulitple UI vision with multiple chrome instance in the same time)

1 Like

Do you use the XModules?

IMPORTANT CHANGE with Version 7 : If you use macros that run more than ~2 minutes you MUST install the XModules .

If you do not use the XModules then Chrome will stop the macro after ~2 minutes at a random point in the macro. :skull_and_crossbones: No error message is displayed. :skull_and_crossbones: The macro just stops. Please note that this behavior is not a bug of our software, but a “feature” of the new Manifest3 Chrome API.

:point_right: Solution: Simply installing the XModules resolves this issue . The XModules app prevents Chrome from stopping UI.Vision macros :smiley:

The other solution would be to use the Firefox version of the RPA software.

thank you for the REPLY. But xmodules is already installed and i cant use firefox because picture upload dont work

Hi, do you have a video of the issue? Some questions:

  • Roughly how long does the macro run before it stops?
  • Do you use the latest Chrome? It must be a version > 100.
  • Is this on Mac/Windows/Liux?

Hi,

  • Roughly how long does the macro run before it stops?
    → After 30 minutes

  • Do you use the latest Chrome? It must be a version > 100
    → Yes

  • Is this on Mac/Windows/Liux?
    → This is on windows

Do you have an email adress to send the video?
Thank you

Email: team AT ui.vision - just mention this forum post in your email.

Just linking these together; it sounds like the same issue: "Receiving end does not exist" - v7.0.9 - #8 by TheWhippinpost

If the OP thinks this is wrong I will remove this post.

My scripts often stop when opening a new tab seconds into the start of a script (Windows, chrome, XMODULES installed). No error messages or other indication.

@dbareis Interesting. Do you have a short test macro for us? If so, we can run it for hours here and debug when the issue happens.

DennisBareis-NormallyFails2ndLine=selectWindow.zip|attachment (347.8 KB)

@admin
I have attached a zip containing the files (it includes logs including those for other issues I have reported):

  1. open “UiVisionLinks-LookForPerson.html” manually
  2. Click on a link like “[QLD Births]” (file:///D:/DBAREIS/TOOLS/UI.VISION/ui.vision.html?storage=xfile&direct=1&macro=RegistryAu(QLD).json&cmd_var1=Smith`George Arthur`1881`1883`B)
  3. As the above step frequently closes the local html file I actually normally now right click on “QLD Births” etc and open in new window. I don’t know if this is a Chome or UIVISION bug.

Line 1 parses the command line and does other setup, line 2 is where it hangs (opening the required URL). I tried it a few times this morning and it didn’t hang (it failed a few times with can’t connect to url?) I suspect varying cpu or other conditions will affect the timing of this issue.

Further to the original post, this happened several times again today; this time after the forced update to v.7.0.11.

It halted several times on the command: storeText