Ui.vision expansion doesn't always work through Windows Scheduler with Google Chrome

Hi. I use UI.vision for Google Chrome, but I encountered such a problem that ui vision does not work through the Windows task scheduler. I tried using various methods “Run only when user is logged in” and “Run whether user is logged in or not.”, But with the google test, chrome just does not start. On the taskbar it, while in the task manager it is visible. As soon as I close the chrome process from the taskbar, ui vision will start working.

Hi! From the video I could not see what command line you are using to start the RPA software? Can you post it here?

As soon as I close the chrome process from the taskbar, ui vision will start working.

So chrome was already open? This could be the issue. If so, then it should work when you start the UI.Vision Chrome instance in a separate profile. To do so, create a new profile and add --profile-directory=“Your 2nd Profile” to your command line. Make sure that UIVision is installed in the new profile. See here:

I run all of my macros w/ task scheduler and have never had an issue. I have the task scheduler call the command through powershell.

Task Scheduler
Run only when user is logged in
Actions > start a program
Program/Script : powershell.exe
Add arguments : -ExecutionPolicy Bypass -noprofile “C:\Users\Path\Path\StartMacro.ps1”
Run task as soon as possible if a schedule is missed - Yes

You can add whatever you need in your PowerShell script but can be one line. Example:

Start-Process -FilePath "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" "file:///C:/Users/Path/MyMacro%20start.html?direct=1&storage=browser&savelog=MyLog.txt&macro=MacroToRun"

Make sure you have a startup macro (the pretend “MyMacro start” above). You get this by doing an Export to HTML + autorun in UI Vision.

1 Like

I can not explain the reason for the failure of the automatic macro. It just does not execute.
This is what I saw when I logged in via RDP to a user

Task Scheduler:
“C:\Program Files (x86)\Google\Chrome\Application\chrome.exe”

Do you have “Run only when user is logged in” selected? Also try adding bringBrowserToForeground as the first command in your macro

What happens if you run this macro via taskscheduler manually, does it work then?

Like this: