"Receiving end does not exist" - v7.0.9

Happened a few times since latest update (7.0.9), triggered by a selectWindow, TAB=Open command.

Hi, thanks for the report. So this issue did not happen before? Roughly how often does it happen? Any suggestion for us to recreate it?

It’s not happened since several versions ago.

It happened 3 or 4-times today, within an hour. It happened last week not long after it updated, several times.

It’s opening a URL from a CSV file. The TAB and web-page opens but that’s where it stops.

I will run it tomorrow and see if I can detect more clues but I don’t think there’s much more I can add, unfortunately. I cannot provide a URL because it’s behind a wall.

It happened one-time in about 2-hours today. This time I closed and restarted the browser which may explain why it didn’t happen again.

No additional insights I can offer at this time. I will probably use it for longer tomorrow.

I’ve lost count how may times this error occured today; at a guess, anywhere around 10-15-ish times over a 5-hr period. Restarting the browser didn’t seem to have any effect in reducing failures.

Once again, I saw no obvious patterns surrounding the error.

I guess you can not share the macro, but can you maybe record a video of the situation when it happens? That gives us hopefully some idea what is going on.

You can email it to team AT ui.vision

Can I ask, what would you hope to see? Maybe I could look out for it; although I’ve never been able to witness it happening in real-time.

I only ask because, honestly, I can’t think what extra detail it would provide. It really is a case of it halting on the command (highlighting it red). The tab is open and the page is loaded.

If you really think it would help, I will try, but I first have to work out if there is any compromising data.

I notice someone else recently reporting the same issue:

Excuse my ignorance, is there a way to rollback to a previous version?

Interestingly, it just halted at the same command:

selectWindow, TAB=Open command

But it didn’t “stop” or produce an error in the log tab. The little green line-number was still visible on the icon in Chrome.

Yesterday I had faster, fibre internet installed - that’s the only thing that’s different ← just in case that may be a factor.

Just throwing it out there, don’t know if this helps to debug it. Apologies if this is just clutter.

OK, further feedback now the run is over.

In addition to the post above, there were two further “halts” on the following commands:

  • storeText
  • assertElementPresent

No errors reported at all.

Again, the only difference is fibre internet installed yesterday. Oh, and v.6.2.8 is installed but I haven’t been able to run it.

Also see following thread: Script suddenly stop

I ran it the day after the previous report and had none of those issues, oddly, but it did revert back to several ‘receiving end does not exist’ error failures.

I’ve been running my macro without this problem for a few days and then yesterday these errors started. A restart and running only 4 Chrome tabs and no other applications and it ran all night, no problem. This morning I stopped it, restarted and the error is back. [forum post: Receiving end does not exist. (TAB=OPEN)]
My Chrome CPU use goes from 2% to 56% during the 5 seconds the macro runs. Is this normal?

Just tried v7.0.13. The issue still persists, seemingly. This time it halted on the command:

selectWindow | TAB=0.

Is this issue still being worked on or has it been solved?

I’m getting it too. Would love a resolution.

We are currently working on fixing a similar issue, which hopefully solves this issue as well. We are on it! Please continue to post test cases etc.

1 Like