[Fixed] ipcPromise: onAsk timeout 3000 for cmd "RUN_COMMAND"

[warning]

Web page connection issue. Retrying last command.

[error]

ipcPromise: onAsk timeout 3000 for cmd "RUN_COMMAND", args "[object Object]"

Been getting a stack of these today after the v5 update. Random, but usually when selectWindow, TAB-OPEN command is played.

Hi, do you get them in a specific macro(s) that you can post here?

It’s a 361-line macro, but the common choke-point is around line 51.

It’s also pulling URLs from a CSV file to open in a new window.

It also operates within a subscription-based member site, so access for testing it would be a no-no.

Given the above, tell me what you would need for your needs (partial code, full code, a csv file etc.). I may have to email it to you privately, depending.

I’m actually now willing to consider screencasting it I’m getting so desperate (I think this update’s made it worse, but that’s just one-day’s usage), but I have to careful. I’ve never actually witnessed it live, so I’m intrigued myself.

Lets wait for the next update (next week) where we will have further improvements to the STOP issue. Maybe this gets fixed by it automatically. If not, we can come back to try to recreate it.

Maybe it’s related with


or

from

Caught it today.
image

@commensal After/during what command did you get this error?

Again.
image

This is when Kantu fails to start on task scheduler.
Another failed attempts to use command run after half a year of hoping for better.
I wonder why there is not many messages about this.
Is this my machine only or people do not use command run option?

Macro is scheduled for run after 10 minutes of machine idle.
When I come back to PC I see browser opened with starting page of the macrofile.
It says it cannot find kantu panel. But Kantu panel is opened.
And there is zero crumbles if it has ever tried to run any macro.
Log is empty.
If I reload the page expecting Kantu to do it’s job nothing happens.
Since Kantu panel is opened I start the macro manually and receive this error.
Needless to say Internet is fine and page from open command is loaded successfully.

Just now I started the scheduled task manually and here we go… something new.
.image

and this time after hitting ok and reload of the macropage it started the macro but surely enough…

image

I used to use the cmd-line to fire-up Chrome and Kantu when a CSV file was detected in a folder, but decided to start it manually until the bugs are ironed out because I couldn’t rely on it.

I haven’t been able to test this new version (v5.0.5) yet but I’m hoping to report my experience tomorrow.

Finally got chance to run v5.0.5 today and can happily report a trouble-free experience! :grinning:

This will not go down well with those still having problems, I know, so allow me to comfort you with a couple of things that kind of broke.

I did experience the following error when trying to open the last line of the CSV file:

[warning]
Web page connection issue. Retrying last command.
[error]
ipcPromise: onAsk timeout 3000 for cmd "RUN_COMMAND", args "[object Object]"

The page itself displayed the following message:

Your file was not found It may have been moved or deleted.
ERR_FILE_NOT_FOUND

The page title (in tab) read:

chrome-extension://gcbalfbdmfieckjlnblleoemohcganoc/

Opening the CSV file in Kantu’s editor I could see the last line showing:

Kantu-error-csv-last-line

Which I believe explains the error. (Anyone know what the red dot means?)

However, I did specifically delete the last line of the file in another editor before running the macro (because it was empty), so I will look at that again next time.

Another lingering issue was the macro slowing down over time. I’m not so concerned about that at the moment - I’m just glad it ran without manual intervention and error-free.

One last thing to note, this was not my usual environment: instead of running it in Firefox, on a fairly new laptop, I used Chrome on my 3-year-old home desktop. I also believe the internet here is better quality than where I normally run the script.

Of course, it’s just one run. I will update again after another, but for me it’s a ray of sunshine… at last!

Thanks to @admin and the team; don’t stop.

For me, this error is very easy to reproduce (Kantu version 5.0.5).

I am working on a very large single-page web app.
This occurs every time I rebuild, ie. the browser cache is cleared.
Simply calling to load the page will cause the error.

Despite TIMEOUT_PAGELOAD being set high; if the open command takes longer than 3 seconds (which it always will do, we have a big web-page), Kantu decides there is a connection issue and retries the command. This is very annoying, as sometimes the page just about manages to load, but Kantu has already decided to give up and refresh again. So I see a refresh loop.
It tries 3 times before it gives up and throws the error.
I can solve this by manually refreshing the page first myself, to re-populate the browser cache. But this is not very good.

This occurs whether I set TIMEOUT_PAGELOAD variable or not. And no difference for the global preferences option either.

Is this a bug, or am I missing a preference or variable?
Let me know if I’ve posted this in the wrong place, I’m new to the Forum.

Kantu%20load%20issue

1 Like

I also have this error. Please do something with it. I cannot use kantu because of this bug! :frowning:

Hi, does anyone have a test macro that we can run here? If you do not want to post it here, please email us at team AT a9t9.com

As I said just a command run with one command open would give you this error. But it seems you’ve nailed it in 5.0.5 I have not faced it since 05 update. Good job. Unless somebody on 5.0.5 can prove me wrong?

@commensal So your saying that in your case the error is gone with V5.0.5? That is nice to hear :slight_smile:

@Denis_Borisov @jgl.b3d What about you? Do your macros also work with V5.0.5? And if not, do you have a test macro for me?

Try this on yours private gmail account. When is ok, dont close current gmail tab and retry start macro again.

{
  "Name": "zzz",
  "CreationDate": "2019-6-26",
  "Commands": [
    {
      "Command": "open",
      "Target": "https://mail.google.com/mail/u/0/#inbox",
      "Value": "val"
    }
  ]
}

Error

[error]
open' failed. No page load event detected after 10 seconds. Error detail: still same ipc secret

@Emil_Szymecki I tried - and it works just fine for me.

This problem
[error]
ipcPromise: onAsk timeout 3000 for cmd “RUN_COMMAND”, args “[object Object]”

I have often bug when i use selectWindow on the loop, and url has parameters with variable
example:
https://calendar.google.com/calendar/r?tab=mc&pli=${kantu_variable}

the error applies to different domains, most often you must be authenticated