7.07 - 7.09 xpath is not working in Chrome (while 6.3.3 in Edge is doing well)

Hi all,

I was using the same script for more than a month to do some downloads of the information on the website (browser - Chrome). I did a script, and one of the actions is to open a javascript link and switch to another window using xpath.

Everything was working perfectly, until 7.07 come. Starting from this version I can see that script is clicking on the link, but it doesn’t make a new window open.
The funny thing is that the same script is working good in MS Edge and RPA 6.3.3, so it is not about something changed in the website.

Is there any option to install older RPA? I tried to use the one from this link Archive - UI.Vision RPA Software but here is only 6.2.8 version, whcich is too old and do not support switching between windwos (my script was not completed in this version for that reason). So is there any option to get 6.3+ for Chrome?
Or is there any other ways to fix the problem?

Thank you

Can you describe what exactly goes wrong? Then we can fix it.

6.2.8 is the last officially supported manifest V2 version. We must switch to manifest V3, and naturally this complex change is causing some teething issues.

But we plan to fix every issue that is reported to us ASAP - so please report more details. Ideally make a new forum post for each issue.

For more details see Ui.Vision RPA Chrome extension: Migration from Manifest V2 to Manifest V3 - #26 by admin

SELECTWINDOW TAB=OPEN SOMETIMES DOESN’T WORK WELL.
ALWAYS APPEARS LIKE THIS:
Could not establish connection. Receiving end does not exist.

I DON’T KNOW IF THE CAUSE IS BECAUSE OF MY PC, OR UI VISION

Hello,

Uniftunatelly it is a closed website, so I can not give you the links or screenshots.
But basically what is happening, is that there is a webpage with several javascript buttons. When you open one, a new window is opened (the old remains the same), and the script continues to run in a new one.
To open this link I used the following code:
xpath=//*[@id=“dateHelp0”]/div/a
To be honest, I do not know to much, how is it working, it was just automatically recorded during macros recording.
After that there is a command selectWindow to switch to a new window.

What is happening - the script is trying to click on the javascript button using xpath. I can see UI logo on the button. After that this command highlight in greeen in UI window, so UI things that it was done, however the new window do not opens after that. So when macro goes to the next command selectWindow it shows error because it do not see new window, since it wasn’t open with an xpath command.

As I told before, exactly the same script in MS Edge version (UI 6.3.3) is working well, which makes me think that there is something wrong with chrome version of the software.

Hope it will help

thanks for the details. I think what you see is this issue:

We will fix it soon.

By the way I need to say, that I was really wondered when I found this kind of browser automation tool. I started to work with it in Feb and found it great.
It actually saved me a lot of time, so I just wanted to say thank you for your product.

1 Like

Hi

Just to give you a feedback, I saw there is a newer version here - 7.0.11
I tried again, and unfortunately, I have the same result, xpath is not opening a link.

Edge version 6.3.3 - is still working good in the same site and with the same script.

The challenge is that we need a test case to recreate and then fix the issue.

Test idea: If you replace the not-working CLICK command with XCLICK, does it work then with V7.0.X?

Hello, unfortunately no, still it doesn’t open the link

Today Edge automatically updated the version of the extension - as a result, scripts are not working neither in chrome, nor with Edge :frowning:

Is there any way to install 6.3.3 back to ms Edge?

V6.2.8 is available in the RPA archive