Xclick/Xtype commands not working on Installation/uninstallation wizard

Hi All,

I’m trying to automate installation and un-installation of an application on windows.
I could navigate through the *.exe file by using Xtype/Xclick with key strokes but once the installation wizard starts, Xtype/Xclick is not working.

Lets say I started the installation with XType | ${KEY_ENTER} on *.exe file, installation wizard opens and there would be “next”/“back”/“cancel” buttons which could not be clicked using Xclick or by using Xtype.

Any suggestions please?

Yes you can do this, you must use xclick and xtype with image, require more time to create a macro to do this.

You must create 1 command for time and you can not recording this macro type.

See desktop automation

You could also be loosing focus. You can do an XClick to regain it

1 Like

@newuserkantu - I tried with image recognition as well but it did not work.

Image recognition working always and in all desktop.

Desktop automation can not fails, probably you create a wrong macro code.

Need only more time to create a macro for desktop automation.

@newuserkantu. Yes it is always working but it did not work only for uninstalling or installing an application.
Just try installing some application and try to press enter or click Next button using Xtype or Xclick.

Only on the installation wizard it is not working.

Creating a desktop automation macro takes a lot of time and a lot of preparation, have you studied well to create a macro for desktop automation ?

It seems that you write that it does not work because you do not want to do anything have you tried?

Publish the complete macro code you made and also publish the full log please.
If you don’t show that you’ve created a macro, no one can help you.

Sometimes you must recorder the image multiple times to have a good quality of image and to create a good desktop automation macro need hours of work (it’s not a work for newbie).

Desktop automation can automate all (installation of software, apps, everything but require coder expert to create it is not a work for newbie users.

After launching chrome as administrator and things worked fine.

I guess I know what the problem is: I assume these installers/uninstallers apps run apps in administrator mode? If so, then the RPA software must also run in administrator mode!

Reason: Normal user level apps can not control admin-level apps. This is by design. It is a Windows security feature.

Solution: Run RPA software as administrator <= it shows how to enter text into a Windows console running as admin. The same solution will work with XClicks on an installer.