Running xmodules as administrator

Hi, is it possible to define that xmodules should be run as administrator so that its possible to control applications running as administrator? I would like to control a application whit xclick.

Windows, Mac or Linux?

I’m using Windows 10.

The UIVision RPA core “lives” in the web browser. So if you launch the browser with “Run as Administrator”, then UIVision runs in admin mode as well => it can interact with elevated admin windows. See here:

I tried running chrome as administrator but it does not work.

Question: After starting the macro, did you manually give the command window the focus? For this tiny test macro this is required (normally XClick would be used for that).

Here is another screencast with more details:

That’s correct. I made the command promt window focus after running the macro. I also runned chrome as administrator.

Just an idea to check: Did you close all instances of Chrome before starting the admin instance?

Yes I did close all chrome instances before I runed as administrator.

Strange, all works fine in our test. If you want, I can give you remote access to our test machine. Maybe you can recreate the issue there?

I’m not sure if I can recrate it on your test machine. I tried on another of my machines but there I don’t have this issue.

Seems like I have the same problem when I run firefox as administrator.

Looks like chrome was running in the background even when all the windows was closed. So when I clicked run as administrator it just used the old instance of chrome that was running as regular user account. When I closed all the chrome instances from task manager and runned chrome as administrator it worked :slight_smile: Thank you for your help solving this.

1 Like