XClick getting the wrong detection

Hello everyone o/

I’m new to the Ui Vision RPA and for about a month I’m using it to create macros to fill forms that I need. Last week my macros that used XClick stopped working and since I started to investigate the issue, I discovered that suddenly the XClick begun to get the wrong detection in the pages and this leads to this 2 problems:

1 - The XClick is clicking out of the place that it should click, slightly down and slightly right from where it was supposed to click.

2 - If I try to select a new area where the XClick should recognize and click, the “.png” saved is also dislocated from where I selected. There is an example:

I have a notebook and an old desktop, and this problem only happens in my notebook. It seems to be a problem with the calibration of the XClick or something alike.

Since this started happening out of nowhere, I don’t know what to do. I use Chrome on Windows 10 and my notebook works with 2 monitors. I already tried to turn off one of the monitors, change the screen resolution, disable adblock on chrome and reinstall the XModule. Nothing worked.

Can anybody here help me? Did this problem already occurred with anyone?

UPDATE

Well I managed to make the macros work again using the solution posted in this link: macOS: XClick on image shifted

So I changed the Ui Vision to the Desktop Mode and I set the Default Vision Search Confidence down to 0.6.

This measure bypasses the problem but it would be good to know if there’s a solution for the Browser Automation Mode :thinking:

I have a notebook and an old desktop, and this problem only happens in my notebook.

Strange. What operating system(s) do you have on those?

We currently have the challenge that this issue shows “only” on some systems…

I use Windows 10 on both. While in the desktop everything is working fine, in the notebook this problem persists