V6.3.1: XRunAndWait gives ERROR: Disconnected

New Version just killed all my macros, nothing is working now as I used a ton of XRunAndWait to run ExcelMacros and python scripts.
When I run just that line it runs fine, but when it’s inside a macro it just gives the error [error] Line 15: Disconnected

The error happens randomly, but surely way more than 80% of the times

It also comes combined with V6.3.1 Loop button does not work (Page load only on first run)

Hi, I tested XRunAndWait just today (see here) and the command works fine. Also, I tested the DemoXRun macro that ships with the RPA software, and it works fine.

=> Do you have a test macro for us? Or a video that shows the issue? That would be very helpful for us to understand what goes wrong.


The error I’m getting

Thanks for the video. Just as a test: If you call a VBS file (any simply VBS will do), instead of the python.exe, do you get the same error?

Of course your program needs Python. This question is just to narrow down the problem.

with VBS is the same, the codes run, but Ui.Vision gets disconnected and the macro stops

I confirmed the problem. It seems there is some kind of timeout happening. If the VBS completes fast, all works fine. But if the script takes longer than a few seconds, then the “disconnect” is happening.

Thanks for your help recreating the issue! We can now fix it.

Thanks again for reporting the issue. The issue is solved with today’s V6.3.2 update.