Possible bug on click and xclick (not getting focus on the field)

Hello
I’m wondering if anyone else is experiencing the same issue.

Problem: click and xclick looses (or maybe not gain) focus right after execution. We can see the green box around from UI.vision showing that the field was detected.

Original macro: Being used for a long time and always worked, so the macro wasn’t changed

Test macro: I created a new macro using only the click and a pause and the issue was duplicated.

OS: Linux Ubuntu 20.04.3 LTS

Browser: Google Chrome|94.0.4606.61 (Official Build) (64-bit)|

FileAccess: v1.0.12
RealUser: v1.0.31
DesktopAutomation: v1.0.42

Video with a simple example
https://watch.screencastify.com/v/nP17kdBti62rac8N2NQO

Thank you
Thiago

Thanks for the video.

Question: Does it work ok if you add BringBrowserToForeground?

Hello admin

I added [BringBrowserToForeground], and fixed for that example form in the video.

Then I tried to do the same on the macro I use on my application and I think I finally found the issue. (I tried both with and without BringBrowserToForeground)
For some reason the xclick event is running out of the detect field. Not sure how much but around 5px down.
You can see from the video the mouse cursor appear on xclick under the detected box.
Screencastify

Just to remember, I haven’t changed the macro neither my application. Only the ui.vision version was changed. Tomorrow I will try to see if I can get running with an old version to test.

regards
Thiago

Please let us know. The recent updates did not introduce any changes to our computer vision calibration.

  • Maybe a Chrome update changed something. If so, the older versions should show the pixel shift as well.

  • Or the web app changed and the XPath points to the wrong location?

  • You can also try with Firefox. The calibration in Firefox works differently (as the browser supports it better).

Hello
Thank you for replying.
I tested on the same computer using Firefox and it worked. (unfortunately executescript doesn’t work on my application on Firefox, that’s why I use chrome, but this could be an issue on my application, have never investigated).
I got another computer, using the same ui.version
FileAccess : v1.0.12
RealUser : v1.0.31
DesktopAutomation : v1.0.42
Chrome: 92.0.4515.159
And it worked !!!

On my laptop i got this version presenting the issue
Chrome: 94.0.4606.61

So it seems like could be a compatibility with the new chrome, but looking at the forum I don’t see any other report on this bug recently. Which makes me wondering that this could be happening only on my computer.

regards
Thiago

Does the DemoXClick macro work on the Chrome 94.0.4606.61 machine? If the drawing has shifted, this macro should show it, too.

For me it works fine with Chrome 94.0.4606.61 (tested on Windows):

image

Before I forget: One way to avoid this pixel shift (if it happens) is to use desktop automation. Because then the browser calibration is not required. I used that in the past (before an existing bug was fixed). See here: macOS: XClick on image shifted - #5 by TechSupport

What kind of screen does it have? Some HiDPI display? There used to be a problem in the past, but meanwhile that is fixed as well.

Hello Ulrich
Thank you for replying. Maybe is something related with Chrome on linux.
I tried and it stops when need to create a new file. Instead of click on the “+” to create new, it clicks on “folder”
image
Trying on firefox it works well.

Hi
Unfortunately for those macros doesn’t work in desktop mode. :frowning:
[error]
Line 4: Locator is not support in desktop mode

It worked well, when using with the demo :). BTW nice suggestion this demo test.

Good to know! The Firefox extension API allows for easier calibration.

For Chrome: One more thing to check: Is the zoom factor 100%? Other zoom factors break the calibration.

Hello
Thank you for replying. It was on 110%, but I tried on 100% and the issue continue to happen. I tried to restart the browser… go in incognito.
​ I dont see anyone else reporting this on the forum, which means, must be something only on my side.
I also tried to upgrade all the ubuntu packages, just in case.
Maybe the solution is to wait some days when a new chrome version arrive to see if works again.
​ If you believe this could be a real bug, you can ask me to make any test. I’m happy to help.
​regards