[#Issue 656. Work in Progress] Firefox Xmodules not working after update

15 days past - no update and add-on is still not usable. Funny cause my firefox is a fresh install. Now even if i want to try if addon is ok I have to restart browser since it’s 60% CPU use after launching kantu. Sad case.

Hi if you have possibility to collaborate with the admin with anydesk or teamviewer to solve this problem, thanks

Hello @admin
i’m using french Win 10
I have just installed the latest version on Chrome and Firefox and the two of them can’t detect the Xmodules.

Hello @admin
After a lot of test i think i have find the problem:

I had kantu 5.1.9 and xmodules 201905 installed and working fine in 2 Windows 7 x64 machines with firefox upgraded.

As lot of people here in the forum, when i tried to update the kantu version or xmodules version i received the error no modules found and 100% cpu and when i close firefox, 2 instances of firefox keeps running in the background and i must close it by hand.

No matter all i try, install only kantu update install only xmodules, unistall first, reboot, i tried a lot of combination with same result, the very moment i updated one of them it all stopped working.

So i decided to try a fresh install in a new test machine, maybe it was windows 7 about to reach end of support, so i installed a fresh windows 10 x64, firefox 71, rpa 5.3.7 xmodules 201908a, and everything went fine, no matter how many times i restarted the computer, every time it detected the xmodules and the cpu use was below 4%, so i thought, problem solved is something inside windows 7, so i proceed to upgrade the windows 7 machines to windows 10.

No luck.
The old versions keep working like charm but when i tried to upgrade everything was broken again, what the hell was happening, maybe any firefon add-on causing trouble? i disabled all but kantu-rpa, same result, cpu 100% and xmodules not working, uninstall firefox, kantu xmodules, fresh install…

Then miracle: xmodules detected, rebooted computer, xmodules keeps being detected, cant believe, reboot once more, xmodules still working, then i had a revelation, i ran to the windows 10 machine test and checked 2 things:

I have not selected my hard drive as storage mode, the test machine still had selected in browser mode.
I noticed instead of using the old kantu folder in desktop i had created a new folder called uivision in desktop and selected as xmodules home folder, so i copied my macros to that folder and:

BANG! everything broken again, no detection of modules, computer unresponsive, 100% cpu.

I thing the problem is when we use the local storage, what is the purpose of installing xmodules in the first place or the new folder name or both of them or maybe none.

I hope this helps you and point in the right direction to solve this problem and if it does, i could accept a xmodules personal license as christmas gift :wink:



Same situation for me

Update: Hooray! User @kantuser logged into our test system and was able to recreate the bug there! So the “xmodules not detected” bug has been located - it happens when there are many (500+ ) macros or CSV files in the folders.

With the latest XModule version we support files > 1 MB size, and this puts more strain on the native messaging communication between browser and app. Now that we know this, we will be working on the fix (Bug tracker ticket #656). This will take some time (1-2 weeks?), as we need to change the way we load files in hard drive mode.

Workaround until then: Remove all CSV files, images and macros that you do not need from the directory, so that only a few are left inside the folder. Then all should work fine right now.

I will update this thread once a real bugfix is available.

(This is not the solution yet, but I mark it as solution for now, so everyone sees this comment :slight_smile:


I have not 500+ macro, i have this bug with the demo macro installed.

I can not use Ui vision because when I installed it freeze firefox, i do not create any macro.

With windows 7 SP1 this bug appears when you install ui vision and xmodules 201908.

I think the subfolder are very slow to load in firefox.

1 Like

@newuserkantu Can you please contact me so I can give you access to our test system? If you can recreate the bug there, then we can fix it in the next 1-2 weeks, too.

I writed an email now from g******i@email.it

***** to avoid spammer in the forum

Nor do I.

@admin Will ya remove please stupid 20 mandatory characters post rule?


a few words about myself:
I am a complete beginner with UI.Vision. I have used WinAutomation for a long time. But I always wanted to have an OpenSource solution.

Now to the problem:
Newest UI.Vision + Firefox
Unfortunately, I could not test UI.Vision properly at all…
After installing the extension it was still running, although the browser was already getting very slow. (CPU at about 40-60%) I thought the cache was full and also I hadn’t restarted the PC for days. I cleared the cache and quit firefox.
CPU and RAM were back to a normal level.

Start firefox - message “Already running, instance must be terminated first” [OK].
After launch CPU is at 60-80% and RAM is filling steadily.
Tabs are not loaded - as if I was offline only without error message.

Task manager check - Firefox is running in 8 processes and after closing in background in 4-6.

fresh installed: same problem again and again.
portable version: same problem
sandbox: same problem

After installing the extension the browser is unusable.
I can switch to the settings and also between the tabs, but no web page is opened and in the window of UI.Vision the scrollbars are missing.

All other applications like e-mail and softphone still work.

What could be the reason for this?
It sounds at least similar to what I read here before.