[Fixed] [bug] xFile is not installed yet

I have launched several times from the task scheduler receiving this error.
Once I launched html from folder and the error did not show up.
Now it doesn’t show up when I run from scheduler as well.
But I know for a fact it will show up again sometime soon (today is not the first day).

Kantu is more & more like a Flying Dutchman to me.

Guys you really need to make a tool for debugging this beast.

Aaaand… it’s back. LOL. :laughing:

We just fixed a maybe related issue for the command line (sometimes settings are not loaded in time). There is a good chance that this also fixes this issue. Please report back after the next upgrade.

The beta channel will be updated tomorrow already, and the production version probably next week.

I agree about the need for a debug log option.

1 Like

Beta Updated. Thanks guys?!

XModules Status: Free Edition
Only the first 10 files displayed.
Upgrade to PRO to add more.

This limit applies only the XModules direct file access. In the standard HTML5 storage mode, Kantu continues to support unlimited macros and testsuites.

Thanks for testing the beta. Please let me know if you continue to see the error with the new version - I hope not :wink:

I see new ones. When I open script exactly five (5) windows of Kantu open up.
I close all of them. Reload the page with kantu test suite. And again 5 windows of Kantu.
It was like that until I restarted the browser.
But after restart xFile appeared again. Sad day. (

And a new one:

Boy this is fun! :grin:

My guess. Something in Kantu loads ahead of the time and boom… there goes an error of any kind.

Thanks for the feedback. We will be testing this further.

How do you call the command line? From a batch file, powershell, task scheduler… ?

Windows task scheduler.

I can confirm that this error occurred for me after I installed XModules, changed the home folder location to C:\User\USERNAME\Documents\Kantu, and clicked ‘Test it’.

However, after closing Kantu and re-opening, Test it doesn’t report an error. I should add that I also copied the sub-folders to the new location, too (datasources, images, macros etc.)

I’ve not actually tested the module yet (I’m a new user).

I get the same erreur when running from a command line. It looks to me that the module xFile is not loaded when Kantu starts then the scripts are not parsed correctly.
If I close Kantu and reopen it then I can see my scripts.

Today I have faced this problem for running Kantu overnight.
In the morning I’ve seen multiple errors “Kantu is not connected to a browser tab”.
I tried restart my macros and every time I received “xFile is not installed yet”.
All errors were gone upon full restart of the Chrome.

We confirmed this issue. It happens with the command line feature when Chrome is not yet running => it will be fixed asap.

What you mean by “not yet running”? I was trying to figure this out by myself and specifically left normal window running while starting Kantu by command line in incognito mode. Is this considered Chrome to be running?
Glad to hear you are working on the issue.

This issue is fixed in V4.2.6. See also [Issue #539] Error: xFile is not installed yet (same issue!)

User @kantuser contacted us, and was able to recreate a new issue (but with the same error) on our test systems. Thanks for that. Now that issue is being worked on. For updates on this issue please follow this thread:

Closing this as duplicate of [#Issue 656] Firefox Xmodules not working after update