Xrun bat not working

hello i can’t seem to make xrun work and run bat file

with content :
@echo off
set “csv=domains.csv”
more +1 “%csv%” >"%csv%.new"
move /y “%csv%.new” “%csv%” >nul

Here is the video of the issue

[https://streamable.com/hrd825]

althoug the de.bat file works fine in windows !

You need to use the full path
Ex.
Xrun | C:\Users\Path\mybat.bat

Hello thanks for replaying , i tired it and it’s still not working
Here is screen and below is the json

{
  "Command": "XRun",
  "Target": "J:\\Downloads\\Ui\\Ui Vision\\del.bat",
  "Value": ""
}

It’s either you need the full path (right click > properties to check) or you need quotes because you have a space in “Ui Vision”

@Rico_DYellow

In your batch file where do you add the path of csv to edit ?

Your batch file how can know the folder destination of csv ?

I think your batch file can be wrong.

Ui vision use datasouces folder to store csv, not your prefered folder.

I think you must read the doc

hi just solved the batch file issue bat file working great it self now with call

everything is located in the same folder .

ii can’t seem to solve the path of files Target .


Your macro command is wrong read other my reply in the forum and check csv path please