XModules ARM64 Binaries for Linux


I need to run UI.Vision XModules in an Ubuntu VM running on Apple Silicon for various reasons. The issue seems to be that the current XModules linux download does not include ARM64 binaries.

I have Ubuntu (ARM64) successfully running in a VMWare VM on a MacOS. Firefox works, UI.Vision without XModules works. I downloaded Linux XModules installer but it can’t be run and after googling it looks like the issue is the binaries aren’t for ARM64, only x86.

There is not issue with running the modules in a Win11 VM on the same machine. So it seems reasonably possible to modify the linux download so it works on arm64 too.

Is there a way to compile Linux XModules so they work on an Ubuntu (ARM64) VM running on a Mac with Apple Silicon?


Over the past couple days, I tried emulation (QEMU) and various other tricks I found online but nothing worked.

@admin If possible to compile the modules for ARM64 linux that would be awesome

same problem , did u solve it?