Xmodules 201908 more bug 100% cpu firefox, not installed, and crash browser need urgent serious fix

@admin @TechSupport

Many users in the forum have reported that xmodules 201908 (a and b) has numerous bugs but nothing has been corrected and currently ui vision is unusable, you can not work and you have to use other better software to work.

I ask the admin for a serious and definitive fix of the xmodules2018 that does not work.

I mention the bugs of the xmodules201908 (a and b) used with ui vision for firefox 5.3.7 and works very badly.

Bug xmodules201908

  • 100% cpu usage
  • multiple conhost.exe process opened (see in the video twenty conhost.exe opened at 0.24)
  • firefox crash
  • xmodules not installed

I ask for a serious fix of problems otherwise it is useless that you sell this product that is full of bugs and defects, who would buy this software so faulty ?

This is a video

Thanks

I appreciate your posts but please do not exaggerate. While there is a problem on your machine and some others, on the majority of systems all works fine. That is also the reason why we have such a hard time to recreate the issue.

Also good to hear that with Version 05 all works fine for you as well.It is double strange as we did not change that much between 05 and 08 version (only xfile changes, no changes to the other xmodules).

Having said that, please email me at team AT ui.vision and mention this forum post. Next week I can give you RDP access to a Win 10 test machine, where you can hopefully recreate the issue.

Anyone else who want to try their luck to recreate the issue is welcome to email us, too! :grinning: Thanks for helping us to make UI Vision better.

1 Like

I think that xmodules 201908 does not work to any forum user for firefox because I tried it on two different machines and it does not work in either.

As he wrote commensal for Google Chrome works and in the forum almost all users use Google Chrome and therefore to them it works while for those who use firefox does not work.

Users who use ui vision for firefox are few because almost everyone uses Google Chrome for this reason you have few reports of problems I think to all users who use ui vision for firefox the xmodules 201908 does not work.

Is there a user who uses ui vsion for firefox with xmodules 201908 and works it properly?

Win8.1x64
Chrome - OK
Firefox - Not installed

Update: Thanks to the help of @kantuser the “xmodules not detected” bug has been located - it happens when there are many (500+ ) macros or CSV files in the folders. Now that we know this, we will be working on the fix. This will take some time (1-2 weeks?), as we need to change the way we load files in hard drive mode.

Workaround until then: Remove all CSV files, images and macros that you do not need from the directory, so that only a few are left inside the folder.

1 Like

Hello Admin I give a suggestion allow in ui vision the possibility to install ui vision without any macro, csv, image demo (html 5 and hard drive) because I noticed that when firefox updates the demo macros the cpu goes to 100% and in these cases can block firefox.

I tried to delete all the demo macros but after a while he reloaded them (html 5 and hard drive).

It would be useful to avoid demo macros to keep firefox lighter and faster.

A good idea could be to provide the zip package with macro csv, images demo, to those who need them can import, otherwise you would have ui vision without macro demo and therefore faster and lighter.

When automatically updating macros (html5 and hard drive) firefox is under strain and can crash.

I tried to delete all the demo macros but after a while he reloaded them (html 5 and hard drive).

Really? This is strange… => That should not happen - only when a new version is installed are the demo macros updated. And once you delete them, they do not show up again (unless of course there is bug…)

With latest version of ui vision 5.3.7 and xmodules 201908 I removed the folder with demo macro, after some minutes i found it again in my pc i never update nothing.

I suggest to not include macro demo and csv and images because it exceed the maximum limit of 10 macros for xmodules free version so it is also useless to install all demo macros.

When opening the ui vision window with set local storage known that demo macros are loaded very slowly, in some moments it also seems to stop and this can cause firefox to block with cpu 100%.

With latest version of ui vision 5.3.7 and xmodules 201908 I removed the folder with demo macro, after some minutes i found it again in my pc i never update nothing.

I can not recreate this. If you like, I can give you remote access to our test system via RDP, and you can see if you can recreate it there. If you are interested, just email me at team AT ui.vision and mention this blog post.

When opening the ui vision window with set local storage known that demo macros are loaded very slowly, in some moments it also seems to stop and this can cause firefox to block with cpu 100%.

That is correct, and this issue will be fixed

Closing this as duplicate of [#Issue 656] Firefox Xmodules not working after update