XClickRelative unable to find the image but XClick is able to

I have a screen recording showing this problem but I am unable to upload it to this forum as I am a new user. The screen recording on my Google Drive is here: [link removed as upload was made]

You can see that the blue button (within the green box of the XClickRelative selection) is identical to the blue button (within the XClick selection). However, for some reason, XClick can locate it but not XClickRelative.

The issue is not solved even when setting the confidence level of XClickRelative to 0.5.

I am using the latest versions of the XModules. I just downloaded and purchased this two months ago.

Hi, I looked at the video. I have two guesses what goes wrong:

(1) Maybe the green box is too close to the corner of the image. => Try to make the image/screenshot bigger.

(2) I see that you use desktop automation mode? Is that on purpose? Usually for websites I would use the regular web automation mode, so ui.vision only has to search the website for the image.

Does any of these suggestions help?

From your video:

Video (uploaded for you):

Hey Plankton, turns out that your first diagnosis is spot-on. After giving more padding to the green area it works now. Thanks!!!