XClickRelative finds target but doesn't click correctly to launch modal-style popup in web automation

I am using XClickRelative to click a reply button. I think the type of pop up I’m trying to launch is what you’d call a “modal window” or “light box”, just meaning it’s the modern overlay style of popup instead of the ancient style popups that launch a separate browser window.

As I step through the macro, I can see that the element is successfully found because of the red box displayed by UI Vision. When I click it manually the UI displays a text field to type my reply, however XClickRelative does not make that field appear.

I tried clicking it manually and selecting the text region in the next step within the macro, to see if the macro could proceed even though it did not appear to work it the previous step. It couldn’t proceed.

I just downloaded and purchased the (Pro) product today, so it should be the most recent version. Currently I’m using Edge just because it seems like that’s UI Vision’s preferred browser. I’m happy to switch to FireFox if that’s a solution. I’d rather not use Chrome but I will if I must.

I have also tried:

  • click
  • selectFrame (or whatever the command like that is called)
  • XClick
  • OCRExtract
  • Clickat
  • Yelling at it
  • hitting the computer with my shoe

Update: As of today I have also emailed support with the specific details of the site I’m working with. Please feel free to reply here and/or by email. Thank you.

Further update: I once got it to work with the recorder using “click” but it only worked once. The same macro never worked again. I guess the hard-coded x-path values aren’t really static even on a refresh of the same exact page. At this point XClickRelative is no longer always able to even find the reply button.

Hi, can you post a screenshot or (better) a video of the issue?

Okay here’s a screenshot

I tried everything over the weekend. visionSearch, visionSearchLimit, etc. Frustrating.


XClick with image or OCR= (but ot XPath!) selector should work fine. Did you try this?

Thanks for the reply.

I tried XClick with image (for about 3 hours, many iterations). XClick with image doesn’t work because the image is small and it always results in no true positive matches or many false positives. I didn’t know about OCR=, I will check that out thank you.

It seemed like XClickRelative was working for a while in terms of finding where to click, but even when it was working I could never get the actual click to launch the modal UI overlay which is what happens when you manually click reply (and what I must achieve). Also it seems XClickRelative is no longer reliably finding the button to click.

Towards the end of the day yesterday I felt like the “limit search” or “limit search relative” vision related functions sound like they could somehow be chained together with XClick or click to make at least the identification of where to click to work reliably but the documentation is very limited and I wasn’t able to figure it out. I have no idea how to get the click to work even when the right area is selected however.

This is usually a good solution for small button. Can you post a screenshot of what you want exactly to click?

I was able to solve this problem with an extra “click” event following XClickRelative afterall! I just had to get the exactly correct x-path for it.