XClick in Desktop app (Mac) gives Image not found error

I am trying to automate a desktop application running on Mac (OS Big Sur - 11.6). While I used Xclick command to launch the application using OCR feature, getting ‘Image not found’ error as shown in the screenshot below.

I even tried reducing the ‘Default Vision Search Confidence’ value to 0.4. But it didn’t work. I have done all the necessary settings as said in the link - Download XModules for enhanced features, Robotic Process Automation (RPA)

‘Find’ option near ‘Target’ is also giving the same error.

Kindly provide your inputs to resolve the issue

This should work!

Did you create the image on the same machine?

does it work if you re-create the image?

Hi Plankton. Yes. I have created image on same machine.

I tried several times recreating the image and to do double click using the same. But it din’t worked. Was getting same error ‘Image not found’ again and again

Hi, do other images works fine?

It doesnt work in Mac
any solution?