XClick can't locate an object by image or OCR

NVR Recorder app is displayed in the foreground, but despite using image search or OCR, XClick was unable to find the object.

The object is OurHome:

If it finds and clicks:

Could this be because of the color of the app’s background? I would greatly appreciate any ideas or suggestions.

Thank you

Hi, for our testing, can you please upload the small “OurHome” image that you are using, too?

Thank you Admin for your prompt response.

The image I used in that Macro is:


I also tested with these images, but got the same result.



Thanks again


Try using Xclickrelative and have a fixed reference. Also it looks like the our home is hidden under the default group. if its a toggle first add a xclick to default group to open up the link.

Thank you Veena!

I toggled the Default Group, used XClickRelative to take the picture, and encountered the error message ‘Cannot find green and/or pink boxes.’

My Monitor has 5120x2880 resolution (5K), does it matter?

Please see XClickrelative picture below.

Thanks again



green box is the reference. read the below link


1 Like

Thank you very much, Veena! Using XClickRelative with a fixed reference worked perfectly, and I am now able to locate all the objects. This command is truly awesome. I greatly appreciate your suggestion. :+1::+1::+1:



1 Like