Version 9.1.3 opens in two IDE windows

I’m seeing this happen today with version 9.1.3:

When there is a prompt command in the script it sometimes open an second Kantu IDE window.

      "Command": "store",
      "Target": "some text",
      "Value": "!clipboard",
      "Description": ""
      "Command": "prompt",
      "Target": "This is a test",
      "Value": "",
      "Description": ""

It does not happen all the time but I know the “prompt” command is triggering it for sure if it happens.
I have seen it sometimes if

  1. Kantu IDE in the side panel is DISABLED
  2. Open a fresh new kantu IDE
  3. Move it to the different screen of my computer (not sure if this needs to be done to see the issue but that’s when I see it)
  4. Start the kantu script.
  5. When it comes to the prompt, the script stops and sometimes it opens a second IDE. The windows with the input window stays in the back

I can not recreate the issue yet. Do you maybe have a video for me?

I don’t have a video recording software unfortunately. Also it does not happen all the time but I would say around 50% of the times.

I was not able to figure out what exactly triggers it. I’m sorry I can’t be more help. But it happened with the script I posted above.

I also just discovered, if you open a kantu IDE with a script from a book mark, that does not close the Kantu IDE when finished it will open a second and a third and more Kantu IDE each time I run a script from a bookmark… :frowning:

That means I would have to go into each of my kantu bookmarks now and make sure the script is closing the kantu IDE after the script finished.

…storageMode: ‘browser’,closeKantu: false}});…

there can’t be used anymore at all.

Strange, this works for me. Can you maybe test this on a second system?

I’m not sure what your mean with second system.

But I have this happening all the time all over the place now in very different scenarios. For example:

  1. I open IDE in side bar
  2. Do stuff
  3. Open that IDE from side bar into window
  4. Execute script from window.
  5. Execute script from Bookmark
    → Have two IDE Windows now open

Using Promt as command in script, will often open a second IDE window over the old one when prompt command is called.

Multiple IDEs windows are still all over the place and it’s very frustrating because everything just worked wonderfully before the side bar was introduced. I really wish the QA would be just better before throwing those things out into the wild.

My scripts are not just simple 10 liners. I try to use this software as a professional product with a lot of run commands and 100+ more lines of code per automation. It would be great if you would use very complex scripts for testing.

I do understand that as you add more features to a product the testing is getting more complex.

I meant to try it on a different machine. The challenge we have is that we can not recreate the “2 IDE” issue. That also explains why it escaped our QA.

I also tried the steps that you described above - but still only one IDE.

A video of the “2 IDE” bug happening would be helpful!

Is anyone else seeing this issue? Any hint on how to recreate the bug welcome!

Another question: What Chrome version are you using?

Chrome version is
Version 120.0.6099.200 (Official Build) (64-bit)

Sorry I don’t have the bandwidth to do deeper QA at the moment.
I also have no screen capture video installed on my work computer.

Issue happens when I switch between side panel and pop up window. and starting scripts from bookmark and sometimes when I use prompt as macro command.

Can you maybe provide Kantu in two version? One with and one without the side panel feature as this version seems to be extremely difficult to troubleshoot?

Maybe upgrading to V123.0.6312.86 (Official Build) helps? At least that is my current chrome version.

OK I will request from my company to upgrade to latest version of chrome…

Happen again today as many other times: Two IDE windows triggered by a Prompt command.
Also to let you know I have several “run” commands in my script as well.

Browser has been updated and still same issue

Hi, do you run the macro from sidebar or IDE? And from a bookmark or normally?

Update: I see the issue now. It happens when the IDE is used AND run from bookmark AND “run” command is used.

We will fix this ASAP.

Thanks! That drove me crazy :).

I think it would be helpful if you have a catalog of scenarios and script to test on before each release. At least we have that here in our company and it’s very common practice.

Can’t wait to have that fixed.

Thank you

We did not see this issue in our V9.1.5 QA testing. So hopefully it is fixed now. If not, please report back here.

I just tested. The issue still persist unfortunately. Just tested and still see the same issue.

I think for now I have roll back the extension to the stable version 8.3.9 and disable automatic Kantu extension update for now and wait for few more version of Kantu be published.

But thank you for looking into this. I know trouble shooting is not always easy.