Version 9.1.3 - Cannot read properties of undefined (reading ‘startWith’)


I have a macro which fills in a value in a text box and click on the button to perform search. Of-lately i have started encountering issues with the Macro run on some of the machines while on other it works perfectly. Attached screenshot with error for reference.

Kindly look into it and fix it or suggest solution.


Hi, we have seen this error, too, but we can not recreate it :frowning:

Even on the same machines it only shows up rarely. Like I have not seen it in the last few weeks.

So if you have any idea on how to recreate this issue please let me know.

Hello @admin,

Thanks for the reply.

We have not found any specific reason/difference but have found that on some machines, the issue is continuously reoccurring and the user is not able to run the macro. Attaching the system configuration of one of these machines for reference.

Screenshot 2024-04-01 151512

Screenshot 2024-04-01 151637

Also attaching the macro part till the command at which it is giving error. i.e. command/line #10

Hope these details would help. Thanks.

There is another observation that if you make some changes to the macro for ex. print something using echo, then it starts running. Even the undo works means with the same commands, the macro starts working without any issue. But it does requires making changes and undoing it every time for making macro to run properly.

Hoping for a prompt reply and fix for the issue. Thanks.

I’m just curious: Those machines where it works, do they use Kantu version 9.1.3 or an older version?
If the other machines still using an older version, then it’s a kantu issue with the latest version.

Also “startswith” is a JavaScript command. I have seen this issue as well sometimes in my scripts. Not too often lately. But it appears to me that the kantu engine is written in JavaScript and breaks at one point, because a value that suppose to be processed within the Kantu app is missing.

Do you see the same issue if you copy the $csvData{0}{0} with “store” in a variable and then use it in your type command?

@noahhath You guessed this correctly. This is indeed an issue of the newer versions. Actually, we thought we fixed it with 9.1.3, but the user report shows that maybe we did not. :roll_eyes:

We still look for a way to recreate it. We have not seen the issue for weeks in our tests.

Hi @noahhath,

All of the machines whether macro is working on them or not are having latest version of the Kantu. I have tried both storing the variable as well as hardcoding the value for the text box but there was no difference.

Hi @admin,

I am not sure but could it be due to less RAM available with these systems as i have observed though i am not sure about it.

Thanks for the replies!

you are not alone. I have the same issue like today since the sidebar was introduced:

Also make sure not to run the script in a browser that has more than one tab open. That seems to be an issue right now as well. My scripts are most table when I run them in a browser window with a single tab.

I don’t think it’s a ram issue. It’s an application issue. That is the error that the Kantu Engine returns caused by an internal Kantu Engine issue. Does not have anything to do with your code. There seems for some reason a variable value reference missing in certain conditions on their end.

I know, bugs are difficult to fix if they are consistent.

Hi @admin,

Is there any progress on this issue? Were you able to recreate it?

If not or if it would take some time, is it possible to downgrade the UI Vision to some previous version so that the macros could run?


We are working on it and hope to have a fix with the update later this week.

Downgrade: We have an archive of older RPA versions, but Chrome/Edge have no easy way to permanently install non-Chrome Store versions.

Having said this, if you have the Enterprise Edition you can control/block/roll-back upgrades. With the Enterprise Edition, we achieve this by having a unique custom Chrome store link for each major RPA version. Since this is quite some work for us, we can only offer this feature in the Enterprise Edition.

This issue is - probably - fixed in V9.1.5.

I say “probably” because with such an hard to recreate bug we are not totally sure yet. So if anyone sees this error again, please report it here.