Unable to use Xclick on Mac OS VPS / Anydesk / TeamViewer

Hi,

I’ve setup Chrome + UI Vision on a Mac OS VPS and connected via Anydesk. However, xclick only seems to highlight the target element but doesn’t actually click it. I’ve included a screen recording showing the setup running via Anydesk.

As you can see from the video, xclick only highlights the “Store” button but doesn’t click it. However manually clicking the button works. How can we use xclick in a remote VPS?

The video can be downloaded here:

Thanks!

Thanks for the screen video! Some test questions:

  • Does the DemoXClick macro work? (Probably not)

  • Did you give the XModules the required MacOS permission?

  • What macOS version is this?

Thanks for the reply!

  1. The demo partially works i.e: the visual assert part of xclick seems to work, shown by the highlighted red box but the actual click part doesn’t seem to run.

  2. I didn’t receive any XModule MacOS permission requirement notifications. I see from the screenshot that there’s a “kantu-xy-host” that needs to be added to the file permission and screen recordings. Where can I find this file? It’s not inside the applications folder.

  3. I’m running this on MacOS Monterey 12.0.1

Thanks!

Btw, will UI Vision be able to run with XModules on Mac VPS’s with remote desktop connection turned off? Like on the Windows version?

It should be already displayed in your Privacy settings, is it? By default, it is listed there but unchecked. Please check the box to allow it. This is the file that is responsible for executing the mouse clicks!

Yes, that will work.

After manually adding the required files to the privacy settings and checking them, it seems to have solved the xclick issue :slight_smile:

But when I start a macro, close Anydesk and re-open it, it seems that the macro is stopped.

Great to hear that the XClick issue is solved!

Can you add a video of this issue, too? Ideally, please make a new forum post for it.

I managed to fix it by changing to a different VPS provider :slight_smile:

2 Likes