Unable to type in Quick Find box in Setup in Salesforce

I am unable to get UI.Vision to type inside the ‘quick find’ box in Salesforce. I’ve tried everything (xpaths, classes) and running into the issue. When I use the record button, it uses a non-static ID, I would like something that is static.

Sometimes the Selenium-style command “TYPE” does not work with certain Javascript on a website. => Use XClick and XType instead, that will work.

This is what I currently have right now, I’ve used XClick and XType and still having the issue

Here is a bigger image of what I’m trying to type in. It’s the quick find text box in Salesforce > Setup:

I’ve tried this as well. UI.Vision doesn’t appear to be finding the quick find text box.

I was able to figure it out. I used a different locator and it works now. Thanks!

Ok, so the xpath is not found. You can of course try to use another xpath and see if it works better. Some RPA users are really good at finding the correct xpath.

Personally I prefer visual automation instead of wasting time with “old school” fine-tuning xpath locators. You can use either image recognition or text recognition (ocr).

So try one of these:

XClick | image


XClickText | Find


XClickTextRelative | Setup#R1,-10 (Use this if OCR fails to find the “Find” word, which is in light grey. The values 1,-10 are just my initial guess (one unit to the right, and 10 down). You need to get the correct values by experimenting with the FIND button.

1 Like

Scroll bar show that, may be it’s contain iframe (Frame) so you will need to check in code . is there any iframe tag is present?
That can be major reason of it’s