Unable to find matches

Hi there, I have just downloaded SeeShell desktop automation and unfortunately I’m having trouble getting it to recognise any screenshots. None of the built in demos work correctly. They are able to open up the browsers fine but as soon as the script attempts to match a reference picture to a screenshot it gives me an error and stops. If I open up the Image Wizard and click Test it just says no matches found.

Are there any settings or logs that I can use to try to debug what’s going on? Would be useful if I could see the overall screenshot that is being searched.

I have just tried installing this on a VM and it seems to make some progress in there. The main difference is that after the installation it asked to restart my machine which it didn’t on my main machine. I’m thinking there is some issue around the installation of the OCR install

Yes, this can be done. First, every error message from an image command has a “View” link to show the screenshot as taken and searched by SeeShell. So you can see exactly what SeeShell saw when the “image not found” error happened:


For a log of the complete sequence of screenshots, go to the “Expert” settings and enable “Save screenshot for every command”


Then, SeeShell logs what it sees for every command with a screenshot. This means it also logs the successful matches and marks the area that it found. This way you can check if it identified the wrong spot by mistake:

Please keep us updated on what you find out.

Is your main machine a HiDPI machine?

I have three monitors though each one is a relatively standard resolution.

When I click on the ‘view’ in SeeShell nothing happens. I can however find the screenshots that it saves in my documents folder.

This is the error I seem to get:

2018-07-26 08:19:50,846 [1] ERROR - OpenCvSharp.OpenCVException: u != 0
at OpenCvSharp.NativeMethods.<>c.<.cctor>b__7_0(ErrorCode status, String funcName, String errMsg, String fileName, Int32 line, IntPtr userdata)
at OpenCvSharp.NativeMethods.imgproc_matchTemplate(IntPtr image, IntPtr templ, IntPtr result, Int32 method, IntPtr mask)
at OpenCvSharp.Cv2.MatchTemplate(InputArray image, InputArray templ, OutputArray result, TemplateMatchModes method, InputArray mask)
at OpenCvSharp.Mat.MatchTemplate(InputArray templ, TemplateMatchModes method)
at CefImaging.ImageDetection.d__1.MoveNext()
at System.Linq.Buffer1..ctor(IEnumerable1 source)
at System.Linq.OrderedEnumerable1.<GetEnumerator>d__1.MoveNext() at System.Collections.Generic.List1…ctor(IEnumerable1 collection) at System.Linq.Enumerable.ToList[TSource](IEnumerable1 source)
at Cef.Desktop.ViewModel.ConfidenceLevelControlViewModel.StartCheck()

Interesting. So just to clarify: On the PC SeeShell’s image search does not work at all, or?

Some more questions:

  • What Windows version is installed?

  • 32 or 64bit OS?

Yeah. Can you try reinstalling and then doing a manual reboot? For some yet unknown reason the image search DLLs do not work.

I’m running Windows 10 Enterprise 64bit. I tried uninstalling, reinstalling and manually rebooting and had no change in behaviour.

As a test, can you please check if you get the same error with Seeshell Browser?

Sorry for the delay in replying, I have just tried the Seeshell Browser software and it seems to work fine. It is able to use OCR correctly and goes through the demo scripts without any issues.

Could there be some permissions or something like that required to be changed to allow Seeshell desktop to work correctly?