UIVision RPA 7.0.9

Attempting to open Gmail url - "https: //accounts.google.com/signin/v2/identifier?continue=https%3A%2F%2Fmail.google.com%2Fmail%2F&service=mail&sacu=1&rip=1&flowName=GlifWebSignIn&flowEntry=ServiceLogin"
getting Error “Refused to evaluate a string as JavaScript because this document requires ‘Trusted Type’ assignment.”

Attempting to open Yahoo mail =

" https ://login.yahoo.com"
getting error = “Refused to evaluate a string as JavaScript because ‘unsafe-eval’ is not an allowed source of script in the following Content Security Policy directive: “script-src ‘unsafe-inline’ ‘self’ https://s.yimg.com https://s1.yimg.com https://query.yahoo.com https://*.query.yahoo.com https://y.analytics.yahoo.com https://jsapi.login.yahoo.com https://fc.yahoo.com https://e2e.fc.yahoo.com https://pr.comet.yahoo.com ‘nonce-3R12aXcJENpNxq9OvQ3xTHbUjAQFEO5Cl4NPaBf/RhO+37zE’”.”

Booth worked fine before update.
Executing the macro in Incognito mode

Issue confirmed, thanks for reporting it!

I am also having issues with RPA 7.0.9. I have run essentially the same very long script dailys since about 2/1/2021. Todays run has stopped 5 times with no error message. I am only 2/3 of the way through the script. I have not yet noticed a pattern of when it stops. I willl try to provide more information but likely a couple days because of workload. How can I go back to an older version in the meantime?

Hi, can you please provide a video of the macro running? Even when there is no error, it might give us some clue on what could be going on. You can also email the video to team AT ui.vision if you do not want to post it in the forum.

Todays run has stopped 5 times

  • Out of how many runs? 5? or 500?
  • And how long is the macro runtime? 10 minutes? or 3 hours?

Older version:

See Ui.Vision RPA Chrome extension: Migration from Manifest V2 to Manifest V3

Macro has 88 unique searches. Run time is about 2 hours 15 minutes. I typically launch when I go to bed. I will attempt to do a screen capture and turn into MP4. I think the total failure count was 8 for last nights run. Finally finished about 6:30 PM mostly because each time it stopped I would have to be at the computer to notice. The last time it failed was likely between 11:30 AM and 4:30 PM this afternoon. Could get an approximate time if useful. Friday night’s run is started early, typical launch at 7 PM. 7.0.9 seems to be running significantly better as it has completed about 29 of the 88 searches and has so far worked as expected. The first 22 are the fastest, the middle 44 are the slowest and the last 22 are second fastest. This is because of the number of inputs and time for the web site to respond not the performance of RPA.

The last failure happened at shortly after 11:38 AM Pacific Time. Since 5:26 PT I ran the last 23 searches that did finish AND all 88 searches that I typically run early at 7 PM on Friday evenings. As of now, RPA 7.0.9 appears to be working for me. Earlier stops were just after 11:00 AM, 8:49 AM, 7:52 AM, 1:23 AM. The remain three failures would have been between 7:52 and 11:00 AM but short in duration as I was trying to watch so the gaps in my timeline are small enough they don’t jump out.

The good news is the issue whatever it was appears resolved sometime between 11:38 AM and 5:28 PM.

Fixed with V7.0.13 - What's new with UI.Vision RPA - Visual Automation plus Selenium IDE