UI.Vision keeps crashing since update

So I have been using UI.Vision Kantu to run a macro on a website and do data scrapping. It was working well for a month and a half and I was able to run a lot of my macros correctly for a long time.
Until about a week ago everything was working well.
Then there was a electrical shutdown at my office and everything got rebooted.
When I opened it UI.Vision said it was updating.
Since then, every time I run a macro, it keeps on stopping after about 2 hours of running the same loop (I used to be able to run the same loop for weeks).
It also disables itself as an extension for chrome and I need to go in More tools>Extensions>Reload.
This is pretty annoying, and I wonder why it is happening, as everything was running super smoothly before the updates.

I am currently using Chrome on an IMAC (Catalina).

(Same computer as before…)
I tried using Firefox, but that didn’t help as the loop just stops functioning after around 50 loops (it just freezes)

So right now I just keep on re-running the loop every two hours, as in any case the data has still been put in the csv file I am creating.

Anyone else with this problem ?
Any solutions ?

1 Like

Have you tried uninstalling and reinstalling the extension (saving the macro of course) ?

I used to be able to run the same loop for weeks).

So you had the browser open for weeks, and running a loop all the time? How many loops where this? 1000? 10000?.. :wink:

it keeps on stopping after about 2 hours

Stopping means crash? freezing? Or an error message?

About 13000 loops, but I need to re-do them for multiple things (It has run fine with the 13000 loops and finished them before)

By crashing I mean the window says AAAAWWW the browser has closed.
And then I need to reload it on the extensions thing in more tools, because the little icon has disappeared.
(I have also just changed so that it uses only my computer memory and not the browser memory, and it still has a problem)

Literally the only thing I can see that has changed was the update.

What was the last version working fine?

I am guessing it was V5.3.7 which was working fine

The same issue for me, Windows 10 Chrome, upgraded to 5.3.10 a few days ago, crashes after some time running a loop (an hour to few hours). Previous version was 5.2 I believe (called Kantu).

Chrome itself has updated also. Periodically check the Chrome task manager and watch the memory footprint and CPU on everything to try to narrow it down

Hi, downgraded plugin to 5.2.3 and no issue since then so seems to be more the new plugin version issue.

We confirmed the problem, and are investigating it. Of course, this will be fixed ASAP.

One workaround (and a good method in any case) is to start each macro with the command line api to run a macro non-stop.

The other workaround is to downgrade UI.Vision RPA to V5.2.3, just as @Michal_Ropka reported.

1 Like

Update: On one of two datascrapping windows that I have continuously running, Kantu hasn’t crashed in over 12 hours. The only difference is that I added a command “gotoif”, so that if the previous command is an error it goes to the end of the loop and starts again. For me that’s fine as if one command is an error it means that the rest of the following commands are useless.

I am now testing out another loop, which did shutdown, and just adding the gotoif command. This loop does not really have any errors usually, so the command is a bit useless, but that will help test out if adding gotoif is a good work around.

If it works I’ll keep you informed. But at the very least it’s worth a try.

Let me know once there is a new update, I can test it with my scripts.

same problem with me when using latest version, so i downgrade to version 5.2.3.
my kantu running on windows 2012 r2.

Same issue on 5.3.10 crashing frequently after around 2 hours :frowning:
Please fix the issue…

Same here. After 10-20 minutes crashing and kantu page becomes total white with message “something went wrong” and a blue button to reload page of Kantu.
Also command VerifyElementPresent not work (or Gotoif command not work).When found that element is missing , it should execute a command Gotoif but finally is not executed and then log says “time out waiting for element” .But element is normal to not appear on page so kantu should execute command Gotoif but is not executing.
They are 2 separated problems.

Issue found and fixed. Here is an internal test release for Firefox (V5.3.14):


Please test it and let me know if you still see any problems.

Hi i tried Firefox (V5.3.11) and Firefox (V5.3.14) and have a new bug read here

Any results of testing on Firefox ? Please is it possible to have the test for Chrome ?

Yes, i found another bug in command line folder=XXX option do not work and testsuite can not start via command line

@admin please fix this bew bug in virtual machine there is not free space to recorder a video but this is a new bug.

Application is not crashing on your browser ? Here is crashing always on Chrome after around 20 minutes. Can not work at all.Always showing message “something went wrong” and Kantu becomes a white empty page with a blue button which say “reload” .