Ubuntu 18.04 with Chrome - Native host has exited when using Xtype

Hi all,

I’ve been running a script with no problems for several months but now using 7.0.13 on Google Chrome I’m getting a “Native host has exited” when trying to insert a text string into a search field using Xtype. It’s been working fine and now always fails. I’ve seen those bug fixed previously and I think it might of regressed back into the .13.

Is anyone else seeing this? Has it been raised already?

Regards and thanks,


Hi, just to clarify: Does any XType command fail? Or “just” on some specific website?

If you run the included “DemoXType” macro - does this work ok?

Hi there, thank you for replying.

Just tried it on a completely different website and I still get the same issue. I’ll try with the demo now.

So strangely the macro works fine on another Ubuntu 18.04/Chrome device using 7.0.13 but not on a newly build machine running exactly the same Ubuntu/chrome and Vision 7.0.13 combo.

I reinstalled the XModules elements again just to make sure they all installed correctly, same issue with it terminating on XType with “Native host has exited”

Just to confirm, it also failed with the DemoXClick and DemoXType

I’m starting to think that this might be a browser setting issue with Chrome. It works on one hosted provider VM using Chrome but not another provider’s version of Chrome. Does anyone have any hints? I think it might be security-related but can’t see anything obvious. Any suggestions are welcome! TY