[Test case needed] Getting an error while runing macros via test suites in Kantu

selenium-ide

#1

Hi

I have list of 8-10 test cases which are running successfully as macro. However i have clubbed these test cases in Test suite and getting error below randomly after run of first test case.

  • [error]

empty stack

  • [error]

Can’t find monitor target with id ‘1554791928345.4eda47’


List of open bugs
#2

Hi

Am facing this issue because in every test case am storing value in variable using Store module.

However it runs successfully when am running each test case individually but when i try to run all the test cases in test suite then in every test case it is not able to override value of same variable and throwing an error above.

I have checked one of discussion on forum and at the end of test case i have replaced value of variable again with and “” but still it is giving me same issue.




#3

Hi @mit_test

Today i see this error “empty stack” in Kantu.

I used imacros for 10 years and in these respects it was better never giving errors based on page loading, it was very fast and stable.

Kantu is a software with more functions but it has a serious flaw is not well attached to the tabs and often loses control of the tab, many Kantu errors depend on the internet connection or when the internet is slow. It seems to me that this defect depends on the slowness of the connection.

There are various similar errors in Kantu that all depend on the bad management of the internet connection with Kantu and the impossibility of Kantu to work starting from tab without a website loaded, which with imacros instead is not a problem.

Since using kantu I have seen numerous different types of errors and it seems that they all depend on the weak control that Kantu has in the tabs, it takes very little to lose control and no longer manage to control the tab (example with imacros if you close a tab continues to work without problems in any open tab there is, Kantu immediately freezes).

I hope that all these defects will be corrected because Kantu is a good software but still has various defects to correct.

have a nice day


#4

I use Firefox 66.0.3 and Kantu 4.2.7

Today this strange error has occurred, the testsuite has successfully executed the macros 1-3-5-7-9 while it has given errors in the macro 2-4-6-8-10 and yet individually they all work perfectly, I am trying to understand what is this “empty stack” error.

Macros work perfectly well, but when inserted in a testsuite some report an “empty stack” error. if you have any suggestions for solving.

Thank you


#5

Do you have a test for us? I can not recreate this issue or the “empty stack” issue yet.


#6

Hello all,

I got the same error, but the error only occurs if I start the testsuite as autorun.html from the commandline.
Here you can see the log from the commandline

[status] Playing macro login
[info] Executing: | deleteAllCookies | | |
[info] Executing: | deleteAllCookies | | |
[status] Playing test suite Create_Adapter
[status] Playing macro login
[info] Executing: | deleteAllCookies | | |
[info] Executing: | echo | ${!cmd_var1} | |
[error] empty stack
[error] Can’t find monitor target with id ‘1558437539679.895721’
[status] Playing test suite Create_Adapter
[status] Playing macro login
[info] Executing: | deleteAllCookies | | |

and here the log from the kantu extension

[status] Playing test suite Create_Adapter
[status] Playing macro login
[info] Executing: | deleteAllCookies | | |
[info] Executing: | echo | ${!cmd_var1} | |

[echo] NOT_SET
[info] Executing: | comment | open // http://localhost:60861/Authentication/Login?ReturnUrl=%2F | |
[info] Executing: | open | ${!cmd_var1} | |
[info] Executing: | assertElementPresent | xpath=/html/body/div[2]/div[2]/form/div | |
[info] Executing: | click | /html/body/div[2]/div[2]/form/div | |

In the commandline I start the autorun.html of the same testuite in the kantu extension but the logs seem different. I am not surpprised the result has also differences.

Kind Regards,
Marco


#7

This issue is indirectly solved as we have a new test suite concept with V5.0.