Send message on linkedin - I cannot put any text in message window

I have over 1000 invitations request on LinkedIn And I try to create an automation to accept these invitations and to send an welcome message to these guys, but I face the problem that I cannot write any text into the chat. It’s a p (paragraph) an I get this error:

  • [info] Executing: | type | css=#msg-overlay >div.ml4 > div.msg-overlay-conversation-bubble__content-wrapper > form.msg-overlay-conversation-bubble__form > div.msg-form__message-texteditor > div.msg-form__contenteditable > p | zzzzz |
    [error] run command: element found is neither input nor textarea.
    the json look like that:
    “Command”: “type”,
    “Target”: “css=#msg-overlay >div.ml4 > div.msg-overlay-conversation-bubble__content-wrapper > form.msg-overlay-conversation-bubble__form > div.msg-form__message-texteditor > div.msg-form__contenteditable > p”,
    “Value”: “zzzzz”

From what I understand the issue is because type is able to set text only on input & text area. But my question is: there is a way to set some text in my case?
I had tried also with sendKey, but didn’t worked as well…
Any idea or sample is welcome!


We just released the XModules, which contain the XType command. XType is a super-powerful sendkeys command as it is emulating native keyboard events. It works with any kind of input box or editor.

So what you have to do is:

  • Install the XModules
  • Change type to xtype:

“Command”: “xtype”,
“Target”: “zzzzz”,
“Value”: “”

1 Like

you should try record mode to select type area

1 Like

Thanks for the idea. I test it and it almost work properly. The issue is that the inserted text is the target text:

It’s a bug or I made something wrong?

  "Command": "XType",
  "Target": "css=#msg-overlay >div.ml4 > div.msg-overlay-conversation-bubble__content-wrapper > form.msg-overlay-conversation-bubble__form > div.msg-form__message-texteditor > div.msg-form__contenteditable",
  "Value": "<p>qazxsw</p>"

I see the issue… @admin made this mistake in his code sample :wink:

XType does not use a target. It sends the text to whatever element has the focus. That is why you usually use XClick (target) before XType, to make sure the focus is in the right place.

So… this will work:

"Command": "XType", 
"Target": "<p>qazxsw</p>"",
 "Value": ""
1 Like

yeah, @Timo is right. I edited my post above :wink:

1 Like

Muhaha! you made my day!
It works!

I just installed kantu yesterday and it looks pretty cool ( after I test 2-3 similar rpa).
There is any repo where we can put succeded script in order to make life easier for other users?
…like a library of scripts…

Thanks for the question. Demo scripts are always welcome:

You can…

  • Upload to our kantu github repo via a pull request

  • Create a forum post for the scripts, with the source code as attachment. This has the advantage that you can use the post itself to describe what the scripts do - and that users can find it easily via the forum search.

1 Like