Saving files automatically

Hello, I’m new to Kantu and seems to be very good. All what I need seems to work well, but there is one important thing that, if missing, would make unfortunately impossible for me to use Kantu.
Is it possible to save a file (screenshot and CSV) without having to confirm (with ‘enter’) the name of the file? I used in the past iMacros and this was possible without any problem, but at least until now I didn’t find a way to skip this dialog box that prevent the script to run in a fully-automatic way.
I need screenshots and CSV files to be automatically saved and automatically send by email (I didn’t find a way to send emails directly from Kantu, like in imacros, but this is not a problem as I can create a script in Windows to do this action as soon as the file as been created in a folder).
If this may help, I’m testing Kantu 3.1.8 on firefox 61.0.2 (64bit).

When running a macro like “DemoTakeScreenshot” or “DemoCSVSave” no dialog of any kind should appear. If it does, please paste a screenshot of this dialog in this forum.

These commands store the screenshot/CSV inside Kantu’s local storage. From there, you can save the data to your harddrive with the LocalStorageExport command. Again, no dialog should appear - if it does please let me know.

Thank you for your reply. You are correct: running DemoTakeScreenshots there is no dialog/confirmation box. The problem is that, in order to send by email the generated file (screenshot or CSV) I need to access it directly from Windows (while Kantu’s local storage seems to be not accessible outside firefox). On the other hand, when using the LocalStorageExport command, obviously the first time Firefox ask me to choose between ‘open with’ and ‘store on HD’. I select and memorize the second option. Anyway, every time I repeat the DemoCsvSave I’m asked to confirm the file name as in the screenshot below (see next post).
I made this test on a totally-new installation of Firefox Quantum 61.0.2 (64bit) running Kantu 3.1.9

I tested in Firefox and Chrome on Windows 10 and do not get dialog. The CSV file is downloaded to the browser’s download folder without prompt (except for the first time).

If you try with Chrome, does it work for you?

Sorry, my fault. As I’m always using new installations of Firefox portable, I forgot to specify “save files to Downloads directory” in General options. Now is working perfectly. I take this opportunity to make my compliments for the wonderful software, better in my opinion than imacros. Hopying to see in the near future also a “send email” feature. Thank you very much.