Saved macros not loading

I’ve used Kantu/UI.Vision for a couple of years. Since end of last week, UI.Vision appeared to update, but the macros no longer load when I start the extension.

On the left-hand side, I just see a “Loading macros…” message, which doesn’t go away. I’ve tried importing a saved macro, but it tells me it’s a duplicate, so it seems it does still have the macros there - I just can’t see them to run them. I’ve tried making sure Chrome is up-to-date, restarting UI.Vision and uninstalling/re-installing UI.Vision. But no change in this issue.

We have not seen this issue before. Some questions:

  • Is this in HTML5 storage or hard-drive storage mode?

  • Can you try to uninstall and reinstall? Does the import work then?

Thanks for reply. It’s in Local Storage mode. I’ve already tried uninstalling and reinstalling the extension. It first started last Thursday (9th).

Can you email us your backup to team AT ui.vision? Then we can try to import it here.

I’ve emailed you a copy of one of the macros, but I’m not sure if that’s the issue.

I found another Google Chrome profile I’d created a while ago, and it had an older version of Kantu/UI.Vision (5.1.19). It allowed me to import my json files ok. Then the UI.Vision update kicked in, taking it up to 5.5.7 - it prompted me to overwrite demo files, which I agreed to. And then I got the same issue. It just says “Loading macros…” message again.

This exact issue is happening to me also. I also tried creating a new macro and it won’teven run. Nothing happens when I click play macro.

Add screencast please and info about OS and browser version used

Restart the browser: chrome://restart

I noticed a few glitches on the last auto-update but a simple restart cleared everything up

Chrome Version 60.0.3112.113 (Official Build) (64-bit)

OS Windows 10 Enterprise 64 bit

Hi, thanks for the suggestion. Didn’t work for me :frowning:

@mjewell Does this happen in Chrome and Firefox? We still can not recreate the issue here and are searching for clues what might go wrong.

My version is 55.0.2883.87 on Windows 10 Enterprise 64 bit - I’m stuck on updating it at the moment as my company’s laptop isn’t allowing updates at the moment.

I did install it on my personal laptop, running on version 81.0.4044.113. This time, I had no problems with the extension.

On my work laptop, however, it was working fine until the UI.Vision extension updated and prompted to update the demo macros (previous prompts to update them have worked fine).

Yes, this for me too

It only seems to be happening with Chrome. Firefox is working ok.