Running BringIDEandBrowsertoBackground is no good

The number of bugs in this software are so many that it is unusable. For desktop app automation, I ran BringIDEandBrowsertoBackground in the macro. The browser went behind and I could see thre desktop app but then even without giving a command, suddenly browser appears again in the front and the desktop app is not visible.

I am tired of this software. There are no workarounds too. I have reported some 5 to 6 bugs.


suddenly browser appears again in the front and the desktop app is not visible.

I never saw this happen, and use the RPA software a lot.

Are you sure that you are running the macro in desktop automation mode? => Please post a video of this, then we can see. My guess is that your macro does not contain XDesktopAutomation | true.

Note that in web browser automation mode, the real user simulation commands such as XClick, XMove or XType bring the browser back to the front. This is by desgin, as only an open browser can receive native mouse clicks.

Yes, You are right. The problem goes away wehn the plugin is put in desktop automation mode. But I thought the html file which I downloaded to run the macro as a url should take care of that. I mean this is what I do. I write a desktop automation macro, say with the name m. Then, go to api tab and press generate autostart html page and download the html file. Assume it is stored as x.html in the folder /root/Downloads , then I do
firefox file:///root/Downloads/x.html?direct=1&macro=m

I thought since x.html is generated by putting the plugin in desktop automation mode, the plugin should be in desktop automation mode when running the macro m. Am I not correct ? I see may be not, and perhaps I have to explictly put the plugin in desktop automation mode. I will try it.


You have two options:

(1) Switch the global setting to desktop automation. If you only do desktop automation, that is the best option:


(2) Or, if you do web automation plus a bit of desktop automation (like me), then use XDesktopAutomation | true in all your desktop automation macros

This seems to work fine.

1 Like

thanks for the awesome information.