Run via cmd macro with space in the name saved inside a folder in hard drive

Hi @admin @ulrich @Plankton

Today i tried to run via cmd a macro wuth firefox saved in hard drive.

The macro is saved in a folder but the macro name have spaces and ui vision show an error (macro not found) and i see some + instead of spaces in macro name looking the log

Log

2020-06-13T19:20:39.607Z - [error] Can’t find macro with name “myfolder/testmacro±+11111.json”
2020-06-13T19:21:02.374Z - UI.Vision RPA closing

I used this command

Run “SAP” Macro:
tell application "Google Chrome" to open location "file:///Users/admin/Desktop/dummy.html?macro=a/sap&direct=1&closeBrowser=1&closeKantu=1&savelog=log1.txt"

How can i add a macro name with spaces ?

If my macro name is a/sap - 2 how can run it via cmd with ui vision rpa ?

I tried to remove space and works example a/sap-2 works but if i have spaces in macro name can runned via cmd, need some escapes or other solution ?

Thanks to all

Since the command line is actually a URL, we need URL encoding.
So %20 for “space” should work, and / is %2F. =>
a%2Fsap%20-%202

https://www.w3schools.com/tags/ref_urlencode.ASP

Thanks for reply

for / working directly, no need encode i tried in ui vision and working using / directly.

Now i try to encode url to allow space, thanks for support