Run command do not work when is inside a macro started from command line (batch file)

@admin

Today i tried RPA 5.5.3 for firefox but there is a problem with run command.

When you run a macro via command line, RPA do not load macro list, if you have inside macro stated via command line others macro (runned by run command) give error because RPA can not load macro list and do not execute the macro via run command.

Today I found all my macro with error because if will be started via batch file and inside macro cose there are part of macro loaded via run command

2020-03-19T15:54:58.972Z - [info] Executing: | run | /Functions/Save_Screenshot | |
2020-03-19T15:54:59.052Z - [error][ignored] Failed to find macro with path: /Functions/Save_Screenshot

Macro working well with old RPA, but seem with RPA 5.5.3 not load macro list and can not using run command when you have macro started via command line (in my case batch file).

@admin

The same problem there is when you start a macro via bookmarks, need a solution to load macro list in run command otherwise it’s impossible to use run command inside macro started via bookmarks or command line.

Ouch. I confirmed the issue, thanks for reporting it. This will be fixed asap.

As workaround you can use the new switch loadmacrotree=1 (default is loadmacrotree=0)

Hi @admin

Help me to add loadmacrotree=1 (default is loadmacrotree=0 )

Where I must add this loadmacrotree=1 i must add in command line code (batch file) or i need to add in bookmarks saved in browser ?

Can you post 2 example please, thanks

@admin

I think this change is good not to load the list of macros because ui vision is faster but you have to add an exception at least for the macro executed with the run command inside another macro.

When using the command RUN command ui vision should read only the invoked macro and run it (including its path) so it would be perfect.

The problem currently occurs for both macros started via command line and for macros started through bookmarks.

I tryed to add in command line &loadmacrotree=1 but seem to not work, macro will not load and continue with error.

In bookmarks i can not know how i can add loadmacrotree=1

Bookmarks:

javascript:(function() {try {var evt = new CustomEvent('kantuRunMacro', {detail: {name: "Test/Test",from: 'bookmark',storageMode: 'browser',closeKantu: false,loadmacrotree=1}});window.dispatchEvent(evt);} catch (e) {alert('Kantu Bookmarklet error: ' + e.toString());}})();

There are more error in your syntax, try to generate a new bookmark and you see the difference

have not sense closeKantu: false,loadmacrotree=1

because in other option there is : you add =

I tried without success new command loadmacrotree=1 in batch file for me do not work.

Sorry I don’t have the new version yet to test. I just took what admin had posted. Have you tried loadmacrotree:1 in bookmarks?

Right now when I start a macro from bookmarks the macro list appeared but I didn’t add any parameters.

When I added in batch file loadmacrotree=1 the macro list do not load

I confirmed the problems. It seems there is an issue with loadmacrotree=1 => this will be fixed asap

1 Like

Thanks

Fix this bug for command line (batch file and powershell) and for bookmarks please.