[Recreator Required] XClick not clicking the element when viewport is changing to full

I was writing a sample script for flipkart but to find element in full page, I changed viewport to full and then used visualVerify to find the element. Successfully, it find the element but when I used XClick it is not clicking the element just highlighting it. Then, further macro execution breaks.

Hi, can you please add a screenshot or (better) a screencast that clarifies the issue?

Following is the screenshot of the last command XClick. It was supposed to click the img inside pink box but it is just highlighting after viewport is made to full.

Here is the macro:

{
“Name”: “visualFlipkart”,
“CreationDate”: “2019-6-27”,
“Commands”: [
{
“Command”: “bringBrowserToForeground”,
“Target”: “”,
“Value”: “”
},
{
“Command”: “open”,
“Target”: “https://www.flipkart.com”,
“Value”: “”
},
{
“Command”: “visualSearch”,
“Target”: “closePopup_dpi_144.png”,
“Value”: “matches”
},
{
“Command”: “if_v2”,
“Target”: “{matches}>0", "Value": "" }, { "Command": "XClick", "Target": "closePopup_dpi_144.png", "Value": "" }, { "Command": "end", "Target": "", "Value": "" }, { "Command": "XClick", "Target": "searchbar_dpi_144.png", "Value": "" }, { "Command": "XType", "Target": "polo t shirt for men", "Value": "" }, { "Command": "XType", "Target": "{KEY_ENTER}”,
“Value”: “”
},
{
“Command”: “visionLimitSearchArea”,
“Target”: “full”,
“Value”: “”
},
{
“Command”: “visualVerify”,
“Target”: “l_dpi_144.png”,
“Value”: “”
},
{
“Command”: “if_v2”,
“Target”: “${!STATUSOK}”,
“Value”: “”
},
{
“Command”: “XClick”,
“Target”: “l_dpi_144.png”,
“Value”: “”
},
{
“Command”: “end”,
“Target”: “”,
“Value”: “”
},
{
“Command”: “XClick”,
“Target”: “tt_dpi_144.png@0.9”,
“Value”: “”
}
]
}