[Recreator Required] Cannot save macros

I apologize if this question is already answered somewhere. I can’t find any sticky posts or anything referencing this problem. I am brand new to Kantu and/or Selenium, so I’m still stumbling through it. I just installed Kantu on Firefox for the first time and am having trouble with two things.

  1. I can’t save any macros. When I click the Save button, I get an error message that says “InvalidStateError A mutation operation was attempted on a database that did not allow mutations.”

  2. If I forget I have a macro recording and continue to surf the web, when I come back to the macro, I can stop the recording, but can’t see how to clear the entire macro instead of deleting it line by line. How can I clear the entire thing??

If there’s a better way or place to get my answers, please let me know. I would prefer to be able to find my own answers next time, if possible, so I’m not wasting anyone’s time.

Thank you.

Can you add a screenshot of this error? Is this the latest Firefox version? And if you try Kantu for Chrome, do you get the same error?

We have heard about such reports before, but so far are unable to recreate them on our test systems, that is why each bit of information can be useful. Is there anything special about your system or your Firefox?

  1. If you want to clear a large number of lines, the fastest way is to use the source tab.

  2. To delete the whole macro, right-click it and select “Delete”

  1. My software:
    Windows 7 64-bit
    Firefox Quantum 62.0
    Addons: ADB Helper 0.12.1, Adblock Plus 3.3.1, Kantu Browser Automation 3.1.9, Speed Dial 0.1.6, New Tab Overrride 14.1.0 (Disabled)

I have customized Firefox’s UI with custom CSS files (in the profile\chrome\ directory)

  1. I haven’t tried Kantu in Chrome, so don’t know about that.

  2. More info: This error occurs after inputting the name of the macro and clicking the “Save” button, no matter what name I type.

  1. To delete an entire macro, I tried your suggestion: I clicked the “Source View” tab. I then tried to right-click on the text, but the “Delete” option was grayed out, so I selected all the macro text in the textbox and deleted it, but once I click outside of that textbox, another error appears, preventing me from doing anything else, such as recording a new macro: A popup error says “There are errors in the source”, and an error line at the top of the source view section says “Error.captureStackTrace is not a function”

Clearly, something goes wrong in your installation. As a test: Does uninstalling and reinstalling Kantu solve the issue?

Note: Make sure to backup your macros before uninstalling.

I have uninstalled and reinstalled Kantu twice. The error is still there.

I also have the same problem, see here Firefox Quantum 62.0 Update: I can not longer save macros

I noticed that as soon as LastPass doesn’t work, Kantu doesn’t work either. All other addons are not affected.

Maybe it is due to some settings of my User.js

First this error occurred in Firefox version 62.0.2 and later.

I also am affected by this error.

This is interesting information. What Lastpass and Kantu have in common is that they both use HTML5 Local Storage to store data (in our case macros and settings).

But we can not recreate the issue here (yet)… I just tested again and all works fine on my Firefox 62.0.3.

I just updated my Firefox to 62.0.3, but still no luck saving macros.

@Shadow …if you test Lastpass on Firefox, does this extension fail for you as well?

I don’t know. I don’t use LastPass and don’t want to approve of the permissions it’s asking for.

I have updated my graphics card drivers, so far all without any problems. I hope it stays that way, then we know where the bug came from.

I had the same problem, it disappeared when I created a new profile for Firefox. And it reappeared when I changed my Firefox settings to “Never remember history”. And disappeared when I changed it back to “Always remember history”.

Now this is on Firefox 52.7.2 (32-bit), but it just might be the same on the newer versions…

I am also having the same problem, running Firefox 62.0.3 and have remember history selected. The demo files and test suites that are in the chrome extension I use also seem to be missing. The error only appeared after I last updated Firefox. This is the error message as it appears on mine:

Is there any update on this? I’ve tried uninstalling and reinstalling a couple of times, but it doesn’t seem to fix the problem.

We still can not recreate this issue, but there is now a very good workaround: You can switch to file storage mode - please let me know if this solves the issue.

Open firefox as user install kantu addon -> save fail, never demos present.
Open firefox as admin, install kantu addon -> i can save and all demos present…

thats problem only on firefox. chrom is save…

I’ve a admin and a user account on my win7 system.

I tested on Win 7 with a normal user account and all works fine. So we can still not recreate the issue here.

Possible workaround: Install the FileAccess XModule

You can fix this problem by refreshing firefox. Use this link:
And then reinstall Kantu. I have to do this every time I restart my computer. I do not have this problem in Chrome.
Export the macros you create when using Firefox if this is happening to you. You can then just import them back in after you reinstall.