Problem when using "type" command to add fully words in bootstrap tagsinput field, it turns into letter by letter

Hi guys. I’m having a problem with bootstrap-tagsinput. And I can solve it with Xtype, but I don’t want to use any of the X command, because it bring the browser to front, and I can’t do other works. Please help me solve this problem without using Xtype or anykind of X commands.

The problem is I want to add tags for a product, and the tags section is a bootstrap-tagsinput.
I want this:


But whenever I use type command, it goes like this:


Please help.

Hi, do you have a link to a test page?

I automated a similar case and I used a little trick to solve every problem.

I automated Wordpress Woocommerce tag, and I add all tag in same time separated by comma in this mode it saved all tag separated with one type command.

store | tag1,tag2,tag3,tagx | mytags
type | xpath= | ${mytags}

And working like a charm, it save all tags separated by comma.

Post url page and i find a solution for you, usually a good solution for every automation will ben found.

The webiste I’m doing is
Thank you.

Please check my last comment, thank you very much!

For more informations:

I tried to do the store command as you said, but it didn’t work. It showed the same result. Please advise.

Where exactly on this website is this “bootstrap-tagsinput” input box?

Do you see the same issue here?

My solution to this issue is to run UI Vision inside a small Ubuntu Linux virtual machine. I use the free Oracle VM VirtualBox (VBox) for it.

Thank you for replying to me. I am now hiring a VPS service, I prefer VPS than Virtual machine.
And about this:

Do you see the same issue here?
Bootstrap Tags Input

I’m not really familiar with coding, I’m more of a graphic designer, and I use UI Vision to make my works easier.
Here is whay the tag field looks like:


Right now I use this to fill in the bootstrap-tagsinput:

click | xpath=//*[@id=\"product_uploader\"]/div[5]/div 
XType | tag 1,tag 2,tag 3,tag n

So if you want, please send me private contact so I could share the test page, because it needs username and password. I didn’t send it before because I think I’m just purchased the $89.99 package, so I couldn’t get help from email service.

Hope to hear from you soon.

It’s wordpress Woocommerce your site use my solution working like a charm, already tested on Woocommerce.and working well.

Could you please send me some ways to contact, so I could send you the email and password for the account? Because I tried that and it didn’t work. This website is base on wp, too.

I’ve just tried it again and it still goes like this. Please advise, thank you.

To try a solution need to access in the page and try some macro code.
If you can send me in private message in the forum access to the page i can try to automate.

1 Like

I have sent the information, please help.
Thank you so much for your time!

I received your message private i try to find a solution

1 Like

Could someone please help me with my problem, thank you all so much.