Possible Bug. If I activate Kanu(?) (UI.Vision RPA) Module add-on in Firefox 80.0.1 (64-Bit) @Win10 18363.1016 1909 Buttons on Websites disappear and render them useless

Add-on: UI.Vision RPA 5.8.8
UI.Vision RPA XModules for Windows Version
Firefox 80.0.1 (64-Bit)
Windows 10 build18363.1016 1909

Hello, I searched for a “select and copy text” or “unblocking selection” add-on for Firefox, to get simply the text selected on an result of a virus search on VirusTotal, but I only managed to copy one div text block at once, which I found annoying. I then found Copy Fish and tried that as a last resort, to screenshot the virus result page and let CopyFish do the OCR to get the whole text “at once” copied for a non HTML Email. But their protection seems to be that strong, that I didn’t find any “selection or mouse right-click unblocker” or simple method to get to the text only result of that page.

And indeed, also CopyFish ended in a little darkened page with a hint to select the text area by the mouse pointer which changed to a cross for selection. But no red rectangle for selection appeared. I then tried it on other websites, and it did function as expected.

It still don’t work on that VirusTotal Website.

Then I found on a website of a german journal “DER SPIEGEL”, that their Paywall Restriction where blocked. I can normally press a button to accept advertising to read the article, or join an abonnement. But this time the red button on the left disappears on mouse-hover, and I therefore are not able to read the article.

Here’s the URL: https://www.spiegel.de/consent-a-?targetUrl=https%3A%2F%2Fwww.spiegel.de%2Fwissenschaft%2Ftechnik%2Frevolutionaeres-fluggeraet-celera-500l-ihr-fliegendes-ei-ist-auf-dem-weg-a-796a158c-448d-489f-a6d7-a3895eac7e9a

I then tried to find out what’s the culprit by disabling the add-ons one after another. It turned out, that the add-on UI.Vision RPA 5.8.8 (Kanu?) was the culprit.

You may try yourself to reproduce this behaviour.

Thank you in advance.

I didn’t had the time to try your software a lot, but it seems to do the job quite fair, but seems not to handle tables the right way, does it?

Kind regards


Wow, that is a strange bug. Thanks for reporting it! I created a ticket for it.

1 Like

The screenshot reader desktop mode of Copyfish can help here. Admittedly, it is still a bit cumbersome to use (first take desktop screenshot, then select text), but the next update streamline this process.

1 Like

Hmm, is this a question for the RPA software or the Copyfish OCR software?

I noticed it by using copyfish OCR, Isn’t it relying on UI.Vision RPA 5.8.8 (Kanu?)? Like I already admit, I just installed it on last Sunday and doesn’t know yet what it is for (UI testing I think and automating the usage of websites, by automized user handling and actions like cklicking objects, writing text or so, right?)

Copyfish and the UI.Vision RPA software both use the XModule native app for screen scraping and desktop OCR. But other then this shared helper app, they are different tools for different uses:

In other words, you do not need to have the UI.Vision RPA extension installed if you “just” want to use the Copyfish OCR software.

1 Like