OCR not working with Google Drive direct download links

Does anyone know if the service is having issues downloading Google Drive files by use of the direct download link (e.g https://drive.google.com/uc?export=download&id=NNNNNNNN)? The link had been working fine until yesterday. The links are still working fine outside of the Service.

I’m getting these errors on both the website and on the API.

API error
The file or its content is corrupt. Please choose a valid file for parsing.

Website error
Error: All images / PDF pages gave error. None of the image / page was successfully converted. Please check the errors in result area.

Hi, are you saying the OCR API worked with the Google drive link?

I don’t think so, as Google drive links often (always?) go to a website with the embedded document, but not the document (PDF or image) itself.

If you have a link that goes directly to PDF/image, it should work.

After a couple days it started working again, even with the same documents that weren’t working before. So it is solved for now.

Regarding your comment about the Google Drive link, the one I provided in my post goes directly to the document, as it is an “export” link, not a web view one.