Need to use XType to type passwords into Webpages

Need to use XType to type passwords into Webpages.
“Command”: “Xtype”,
“Target”: “${!cmd_var2}”,

Where ${!cmd_var2} = 5dosXg#5M054&&Bw

Currently it types up to # and errors hence after a few times locks the account we are trying to log into
I’m also anticipating it will error on & as well.
How can we get around this and have UI.Vision type “Literal” passwords
I.E AutoIT’s
Send($password, 1) command

Hi, I tested with this small macro and all works ok:

      "Command": "store",
      "Target": "5dosXg#5M054&&Bw",
      "Value": "a",
      "Description": ""
      "Command": "XType",
      "Target": "${a}",
      "Value": "",
      "Description": ""

Does it work for you, too?

Sorry, that won’t work.
The value for var2 is fed by a vbscript and the values will be ever changing.
we’re trying to get around having the eliminate 22 special characters as part of passwords.
If we can get it to type “as is” without regard to special characters we’re good

@admin BTW, I am also getting the Error #180 No connection to Browser Tab in v8.3

Just to clarify: So the issue “only” shows only when passing the value from the command line via ${!cmd_var2} ?

Try with Sendkeys command.

  "Command": "sendKeys",
  "Target": "//input[@name='password']",
  "Value": "xWLV&HF$I3@XdRzH6hcrn7",
  "Description": "Enter the Password."

@admin Correct
I can see in the UI logs that it types up to the # then stops, in testreport log it shows full variable value

@Biswamber_Khandei tried that, however that isn’t an option as the macro will be used for multiple accounts with passwords changing pretty consistently

@admin @Plankton one other issue I have found, running multiple macros to verify, it appears that ${!cmd_var3} has a 7 character limit. Is this a bug or by design? Regardless of what value I assign to the variable it will not type past 7 characters.

Can you confirm with an echo command that ${!cmd_var2} contains the entire string?
If not, I may be off base here as I am not familiar with vb, but you may need to escape the special characters?

I didn’t confirm it with an echo, but it does show the complete string in the “testreport.txt” that gets crwated when vb script starts the “PlayAndWait(macro)” function.

VB translation of the ${!cmd_var2} variable vs UI.Vision are two different things. I would run an echo and see what UI.Vision outputs.

${!cmd_var2} is the UI.Vision translation of the VB Script variable &cmd_var2
when UI.Vision starts it creates a testreport.txt file:
Const testreport = “C:\Program Files (x86)\MyPath\Logs\testreport.txt”
The first line of this report (log) file is: str_cmd = cmd & " " & arg
Which is cmd = Chr(34) & “C:\Program Files (x86)\Google\Chrome\Application\chrome.exe” & Chr(34) & " – " & “” & arg = Chr(34) & path_autorun_html & “?storage=xfile&macro=” & macro &“&direct=1&savelog=”“&cmd_var1=” & username &“&cmd_var2=” & password & Chr(34)
with the values of cmd_var1 and cmd_var2 included.
That’s how I can tell the complete value for cmd_var2 is being carried over, but the macro stops at certain escape characters, in this case #


      "Command": "echo",
      "Target": "${!cmd_var2}",
      "Value": "",
      "Description": ""

prints “5dosXg#5M054&&Bw” or “5dosXg” ?

got that figured out

Now I ran into another issue
We have the need to be able to run more than 1 instance of UI.Vision at once.
We start the macros via VB Script (as mentioned previously), we are able to kill the browser instances opened by UI.Vision from the vbs.
However if we have 2 instances try to run at the same time, they seem to collide and both fail.
Is it possible to run 2 instance at the same time? Not just macros, but start new macros from new vbs