Manual Xmodules install for restricted user

Hi,

I have several Windows 10 wallboard displays that I want to automate with Kantu.
But the user that runs the wallboard displays is heavily restricted for obvious reasons.

Now I do have admin access to these systems but installing Kantu Xmodules under that administrative user only makes it available to the admin user.
I can’t get it working for the restricted user because the Xmodules installer won’t run under his credentials.

I have done, run as administrator, runas and copied files by hand but it either does not work or is installed in the admins c:\users\admin profile.

Is there a way I can install the Xmodues manualy in Windows 10?
So that the Kantu extension will see the files?
Or can I change the Kantu extension settings to look elsewhere fore these files?

Thanks in advance for your anwser.

Gr. Edo

Download the latest XModules and install.
You can make the user as Admin just to install XModules and the make it back as user.
Also tune priveleges so you can access your json scripts.

XModules should run under a non-administrator user also.

Thanks for the quick response.

Yes, I have done exactly that.
Xmodules files are installed in c:\users\adminuser\AppData\Roaming\UI.Vision\Xmodules…
But the chrome/firefox kantu extension can’t see the files
image

I have copied the files manualy to make sure priveleges are ok.
Copied to c:\users\restricteduser\AppData\Roaming\UI.Vision\Xmodules…

But still the restricted user can not use the chrome/firefox kantu extension because it says the fileaccess xmodules are not installed

How can I make the kantu extension see the files?
Can I change some settings in an ini file.
Schould I register a path or dll?

If you use Storage Mode: Local
image

You can import json:
image

There are also some bat files that can be run (user as admin) to add .exe in registry:
Example
:: Change HKCU to HKLM if you want to install globally.
:: %~dp0 is the directory containing this bat script and ends with a backslash.
REG ADD “HKCU\Software\Mozilla\NativeMessagingHosts\com.a9t9.kantu.cv” /ve /t REG_SZ /d “%~dp0com.a9t9.kantu.cv.firefox.json” /f

Thanks again for the help but unfortunalty both options do not work.

Using Storage Mode: Local and imporing any JSON file says:
image

I have also run any *_install_chrome/firefox.bat file.
They run succesfull but even after a reboot still no Xmodule option is available in the Kantu extension.

Does the error in parsing JSON file have a solution?
Might that be the key to the whole problem?

Gr. Edo

What you are asking is very difficult due to the UNKNOWN restrictions (permissions) of your User account.
Maybe @Admin can provide the requirements of XModules to run from the point of view of permissions.

Do you know what policies are in effect ?

I can’t get it working for the restricted user because the Xmodules installer won’t run under his credentials.

The XModules installer does not need admin rights, just normal user rights will do. This is the same as for the Chrome installation. But as you said, your display user is even much more restricted and it seems it can not run any EXE at all.

If you are admin on these machines, can you try the following:

  • make the display user a normal user or even admin
  • install the XModules
  • reset the permissions of the display user to “very restricted”

Does this approach work for you?

If not: How did you install Chrome for the display user?

Yes, you are correct in the installation part.
First windows and applications are setup and than the last thing is setting up the restrictions.
So, I will include Kantu Xmoduls in an early stage of the workstation setup.
Future upgrade of Xmodules will need a re-installation of the complete workstation but as it is possible to use the macros/scripts from a central location that is just a easy job.

Thanks for the quick response, your time and expertise.
Much apreciated!!:smiley::+1:

Gr. Edo

Tips: if you have problem with location like: \192.168.0.2\some\path try to map that network location as K: or something and it will work.