Macro loads but does not start automatically from command line in Firefox 88

Hello all. I have installed UI.Vision RPA 6.2.2 (Released 30-Apr-2021) inside of Firefox 88, running on Windows 8.1 Pro (my older dev box). I was able to create a complex macro that does everything I need, and when I run it interactively, it will do everything I expect, no problem. However, I set up the API HTML and created a desktop shortcut so that I can just click on one icon, and it should load and run.

It ALMOST works - when I click the link, Firefox loads, I see the UI.Vision loader html page (loaded from the Downloads folder); then a few seconds later two tabs open up - a blank tab, and another with the Macro developer interface. My macro was loaded, but it does not start automatically. But if I click on [Play Macro], it runs as it should.

I have tried this with some of the supplied demo macros and get the same result. I temporarily disabled my anti-virus (Avast), but that had no affect either way.

Being this is the first time I’ve ever used it, it is possible I’m missing something - a setting, or file permission, or…well, I’m not sure. If anyone has seen this behavior before, and can help me out with some ideas, that would be greatly appreciated. I’m just a little frustrated - I’ve gotten so far, and the last step, which should be the simplest, just won’t work for me.

Thanks in advance for any help you can provide.

Hi, some questions:

  • Can you record a screen video of this issue?

  • Does the same happen when you try to run e. g. DemoAutoFill from the command line?

  • Same issue in Chrome?

I’m not sure how to record a screen video on this PC - is there a program within Windows 8 to help me, or do I need to find a separate tool for that?

As for your other questions, regardless of which browser I use (Chrome or Firefox) or which macro I attempt to auto-run (including any of the supplied demos), I get the same results: The browser opens, the macro is loaded, but it does not run unless I press the [Play Macro] button.

I have disabled my antivirus, and the PC is running fairly “plain vanilla”.

Other than this odd issue about not automatically starting, once started, the macros are working as expected.

Could something else on my PC be interfering with the automation? Are there programs or extensions I should check for that might be causing trouble?

Please let me know if you have any more ideas. Thank you!

It seems to be an error that is also happening to me, if you click in the white tab what happens?
It maybe is related to the No tab for dashboard yet error.
To record the screen you could use OBS or another free software for that.