Line X: no access ERROR

I have a problem in all my macros, they are all happening the same error in random lines!

The issue:
[error][Line 5]: no access


Post macro code please

Thanks for answering.

This is happening in all my macros… I have already tested with a macro that just opens google and randomly the same error happens. it is not a problem in the code, because the same code that gives the error in one loop does not give in another

Can someone help? explaining to me at least what this error means…

Are you starting the macro via command line?

I start via “play macro” or “play loop…”

I think your browser or ui vision rpa are damaged, try a fresh installation of browser with ui vision.

I dont know… I tried to run a macro on another computer and had the same error.
what does this error mean?

I using ui vision from 2 years, I created hundreds of macros and i never seen this error.

I think you have wrong code in macro code or browser damaged.

Have you tried disabling other extensions and resetting flags/config?

1 Like

I’ve tried even on a different computer…

but i need to know what this error means, i don’t find it anywhere

This is really a mysterious error. As a test, can you please see if you get the same error in Firefox and Chrome?

If yes: Does the issue happen “only” with your macros, or also with the included demo macros?

Im using google chrome, i will run tests on firefox and with demo macros and i will post here.
Thanks for the answer

Tests with demo macros ok, no errors (chrome and firefox)… but both browsers give an error when i use my macro.
I’m starting to think that it could be some configuration of the website or network that im performing the macro tests (it’s a company environment).

but could you tell me what exactly this error means?

At which line do you macros fail? Is it always a certain command? What is in the Line5 that shows this error?

At the moment all I can think of is that you use executeScript and the website blocks access, but then the error should say CSP error. CSP stands for (Chrome) Content Security Policy error. The website blocks the Javascript execution.

So it seems the security of the website is blocking some Selenium IDE style command. All Selenium commands work technically by inserting Javascript into the website. I guess with your next answer we can find out what command(s) it is that fails.