Kantu highlighting but not clicking (Solved)

I’m new to both Selenium and UI.vison Kantu. Using Google Chrome.

I’m trying to click on video links.

When I use the record function, Kantu works fine. When I playback the script just created I can see the desired link briefly overlayed with a transparent green rectangular box with the UI.Vison logo and the desired link is activated or ‘clicked’ which I’m guessing is what is supposed to happen.
The command created by the script is Click
and the target is //*[@id=“video_310683591”]/div[1]/div[2] just to show you that Kantu is set up and functioning correctly.

So here is the problem…
The names of the vids change periodically so a direct link to any vid is impracticable for those reasons.
So I created a Click that uses

//*[@id=“videosTrayInner”]/div[11] as the target because ‘videosTrayInner’ contains all the vids in the playlist and the /div[11] indicates the child selector (or whatever its is called in Kantu.)

When I run the command I get the same transparent green rectangular box with the UI.Vison logo and it appears over the correct link as desired but the link isn’t activated. It is targeting the correct link apparently but not clicking on the target.
Also, the log clearly shows

[info] Executing: | click | //*[@id=“videosTrayInner”]/div[11] | |

That’s the best I can do as far as wording, I just hope that makes sense to someone because this is driving me nuts.

the reason why the click was not working
When this is used Kantu was showing the correct target ‘the transparent green rectangular box with the UI.Vison logo’ which I metioned’ but was NOT clicking on it.
[@id=“videosTrayInner”]/div[11] /div
by adding the /div to the end solved the issue and now both click and Xclick are working!
Can I get a woohooo?
Yep, this was caused by my inexperience with xpath but then this is how we learn stuff so…
I won’t even miss those hand fulls of hair I yanked out of my head.

As a test, if you change CLICK to XCLICK does it work then? You can keep the same locator. XClick sends a real mouse click to the location, sometimes this works, wenn the “Javascript-level” Click does not work.

Thank you for the prompt reply.
I should have included that I tried Xclick as well.
when playing the command using Xclick I get the same transparent green rectangular box with the UI. Vison logo appearing briefly over the correct location which is followed by the whole screen flashing acid green (or whatever shade green that is :slight_smile: ) but again the video is not being activated (clicked).
just to be clear, recording a click on the same vid works during playback. But I need to automate going through a playlist.
I have been experimenting meanwhile and attempting to resolve the issue on my own.
Just so that the next noob might benefit from my head-scratching.

Links and buttons directly recorded work fine. I’ve also thought of and checked for invisible layers which might interfere and disabled adblockers and other script utility extensions just to check if they were causing issues.
so far nada.
if I find a solution on my own I will post it here.
if nothing else it’s a good reason to read the dang docs lol.
Anyway, thank you very much for your time and efforts.

Bit of an update.
I tried using the mouseOver command on the same element.
The website in question here places a white border around a vid when the mouse cursor is over it so i wondered if mouseOver would trigger that reaction, it dose.
So i can target the desired element and trigger a mouseOver hover event but not a click or an Xclick.
the plot thickens…
This is going to be something silly or sinister.

Just letting you know i figured it out and now both click Xclick are working!
didn’t work because Kantu needed a trailing /div
The above line works perfectly.
Thanks for the help! you got me to poking around and trying different things.