Kantu does not recognize object in web skype


#1

I can write message in a web skype chat with Selenium IDE using the following
Type | name=messageInput | Hello, world!
Kantu does not see locator name=messageInput
What is a locator should be used for Kantu, anybody help?


#2

Hi, are you sure it works with the new Selenium IDE? If so, it would be great if you can post (attach) your test case.

Because when I use edit Content it enters the text, but the Web UI of Skype gets confused and the “Send” icon does not appear. => Exactly the same in kantu and side2.

But what works great is to use XClick/XType (only available in kantu) to enter the text - then all works just fine.

editContent method (fails for me in kantu, side and katalon)

xtype method - works :+1:


Note that before XType you first need to do an XClick | locator to set the focus on the input area of skype.


#3

Hi,
It was working with IDE on old web skype version in FF. For now MS does not support FF for web skype. As you advice to use XType but it requires to install XModules, is any way to solve this with only pure js?


#4

May I ask why this is a problem?


#5

I wanna have a simple portable code between browsers and OS, any additional installations of software compicates that portability


#6

I agree that a solution without xclick is preferable because it runs a bit faster and can run in the background. But in the Skype web app case I tried with katalon and the new selenium ide and did not get it to work. If you get it to work with these, let me know. Then I am sure we can find a kantu solution without xclick, too.
=> So at the moment the only solution that works at all is with kantu with xclick.

The XModules work on Mac, Linux and Windows + Firefox/Chrome and are 100% compatible. So my little xclick+xtype solution will work on all these versions without changes.


#7

Thanks, for sharing this information.


#8

I tried to use XClick it works very unstable, one run time only it worked while manual debug, but all the rest time script hung up or me getting the errors like
[error] failed to XClick viewport coordinates [865.1, 574.5]


#9

@Alex1 Can you add a screencast that shows the issue?